after reloading a URL, an "Offline Mode" message is displayed

UNCONFIRMED
Assigned to

Status

()

P2
normal
UNCONFIRMED
a year ago
a year ago

People

(Reporter: grgoffe, Assigned: valentin)

Tracking

53 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [necko-next])

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:53.0) Gecko/20100101 Firefox/53.0
Build ID: 20170518070317

Steps to reproduce:

I'm running the latest "Released" FF version on my Fedora 27 (rawhide) system. I am running the add-on "No-Script" which disables sites from executing their code on MY SYSTEM. I do this for security reasons.

I was editing a URL and had poked the "Submit" button and I got a small popup complaining about no "Captcha" data. This usually means that I have disabled a required site. I enabled more sites and tried again (NO-Script reloaded the page). The next page I got was NOT the one I was editing but a page that seemed to be claiming that I was in "Offline Mode" and asked me to try again. I tried again via the provided "Retry" button and got the page that I was editing.

I repeated this several times and each time the same thing happened, as above. I finally enabled the "Captcha" site and the "Submit" took effect.

Why is FF showing the "Offline Mode" page and not the page I was editing?


Actual results:

see above


Expected results:

see above
Component: Untriaged → Networking: HTTP
Product: Firefox → Core
Hi George,
Can you reliably reproduce this issue? It would be very helpful if you had a link where we could trigger this bug, or if you could reproduce it yourself and gather some logs using about:networking
https://developer.mozilla.org/en-US/docs/Mozilla/Debugging/HTTP_logging
Thanks
Flags: needinfo?(grgoffe)
(Reporter)

Comment 2

a year ago
Valentin,

Thanks for taking your time with this bug.

I can't seem to find the URL and am surprised that I didn't include it with this bug. Sigh. I hate it when this happens.

If you want to close this bug, please feel free to do so. When/if it happens again, I'll remember this lesson.

George...
Flags: needinfo?(grgoffe)
Thanks George. I'll close it for now. Please reopen it if you manage to reproduce it in the future.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → INVALID
(Reporter)

Comment 4

a year ago
Valentin,

Here's a URL that shows the problem. I started with no-script totally disabling all access which left me with a pretty bare screen. Next I enabled just the site (https://web.charityengine.net/Default.aspx?tsid=8903&trackingcode2=food&trackingcode3=Mobile&trackingcode5=&trackingcode1=WDACT). This gave me a popup asking for permission to resend the data. I poked the "ok" button but got the "Offline Mode" URL.

Is this enough info?

Regards,

George...
I still wasn't able to reproduce it on Firefox 56. I'll try some more.
It does seem like there's an issue with POST requests and the way no-script refreshes the page. Not sure if the webextension port of no-script would also be affected.
Assignee: nobody → valentin.gosu
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
Whiteboard: [necko-next]
You need to log in before you can comment on or make changes to this bug.