mouse middle button (wheel button) goes too far back in history

RESOLVED WORKSFORME

Status

SeaMonkey
General
--
major
RESOLVED WORKSFORME
16 years ago
13 years ago

People

(Reporter: scottd, Assigned: Brian Ryner (not reading))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9+) Gecko/20020411
BuildID:    2002041108

On the Windows versions of Mozilla, clicking the middle mouse button takes you
back one page, just like if you clicked on the Back button in the toolbar.

On Linux, this seems to take you back to the last site, rather than the last
page.  If I go to to mozilla.org, then slashdot.org, view multiple pages at
slashdot, click the middle button (mouse wheel button on my Logitech), I go back
to the last page at mozilla.

Reproducible: Always
Steps to Reproduce:
1.Go to a web site
2.Go to another web site, then view multiple pages there
3.Click the middle mouse button and you go back to the site in step 1, not the
previous page of the current site

Actual Results:  I went back to the site mentioned in step 1.

Expected Results:  I should have been taken to the same page as when I clicked
the Back button in the toolbar.

Comment 1

16 years ago
I wasn't aware that the middle mouse button could be used for going back.

Do you mean just clicking the middle mouse anywhere or somewhere specific?
Giving to browser-general. Is this  a supported feature? 
Assignee: radha → jaggernaut
Component: History: Session → Browser-General

Comment 3

16 years ago
Hmmm... The only thing I could find is in Preferences under Advanced -> Mouse
Wheel: ( ) Move back and forward in the browsing history.

I would expect that to happen when you scroll the wheel, not when you click. I
don't know if clicking the mousewheel to go back is supported, and I certainly
can't explain why it goes back multiple pages instead of one. Actually, one
silly reason could be that a click on windows is one down-scroll of the wheel,
where a click on linux is e.g. three down-scrolls of the wheel.

-> bryner
Assignee: jaggernaut → bryner
(Assignee)

Comment 4

16 years ago
Clicking the mouse button in the content area on Linux will send you to the url
that's on the clipboard.  Are you sure that's not what you're seeing?

Comment 5

16 years ago
AFAIK there is no middle-click "Back" feature on Linux?

scottd@cloud9.net:
If you middle-mouse click in an editor, and then in the browser:
Does the browser take you to the same or similar page as what you pasted in the
editor? See also question in comment 4.

In order to reply, use link to bug near top of bugmail, and then write in form
for "Additional Comments" on web.

Comment 6

16 years ago
there is an option in prefs for mousewheel to go back/forth in history
but that is a mouse-wheel scrolling  behavious, and not used by middle-mouse
click, as far as i can tell. When testing it on a current CVS build, it takes me
 back/forth  one page at the time.
Marking WFM per comment #6, because the reporter hasn't provided additional
details in two months.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.