Closed Bug 1371969 Opened 3 years ago Closed 3 years ago

Images without embedded color profile render incorrectly

Categories

(Core :: ImageLib, defect, P3)

52 Branch
defect

Tracking

()

RESOLVED DUPLICATE of bug 455077

People

(Reporter: u596779, Unassigned)

Details

(Whiteboard: [gfx-noted])

User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/59.0.3071.86 Safari/537.36

Steps to reproduce:

Open any local or web-hosted color image not tagged with a color profile.


I use MozillaFirefox-52.1.1-57.9.1.x86_64 on openSUSE Leap 42.2

I am also using oyranos with correctly selected monitor profile. My monitor is wide-gamut and calibrated properly. In gwenview and RawTherapee I see colors correctly for all untagged images.

The test shows the same result in the latest stable Windows version.


Actual results:

The untagged images are oversaturated (incorrectly color managed)


Expected results:

The untagged images should appear as if tagged with sRGB profile.
Component: Untriaged → ImageLib
Product: Firefox → Core
If you go to about:config and change gfx.color_management.mode from 2 to 1, it will solve the problem for you (note that already decoded images will be wrong, restart to be sure). Many years ago it was determined it was too costly to enable all the time, although I do wonder if that is still true today. Something to investigate. I note that Chrome 59 has the same behaviour as us, untagged is not adjusted for sRGB, from what I could tell at http://cameratico.com/tools/web-browser-color-management-test/.
Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Priority: -- → P3
Resolution: --- → DUPLICATE
Whiteboard: [gfx-noted]
Duplicate of bug: 455077
(In reply to Andrew Osmond [:aosmond] from comment #1)
> If you go to about:config and change gfx.color_management.mode from 2 to 1,
> it will solve the problem for you (note that already decoded images will be
> wrong, restart to be sure).

I know that about:config workaround but it is not a fix. 99.9999% of people won't do it and will keep seeing wrong color.

> Many years ago it was determined it was too
> costly to enable all the time, although I do wonder if that is still true
> today. Something to investigate.

But how come in Windows it is ok but in Linux it is too costly? I hope you can fix this.

> I note that Chrome 59 has the same
> behaviour as us, untagged is not adjusted for sRGB, from what I could tell
> at http://cameratico.com/tools/web-browser-color-management-test/.

I know and I have reported that one too.
You need to log in before you can comment on or make changes to this bug.