TestPrintf is not executed on automation

RESOLVED FIXED in Firefox 56

Status

defect
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: ekyle, Assigned: marco)

Tracking

(Blocks 2 bugs)

Trunk
mozilla56
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox56 fixed)

Details

Attachments

(1 attachment)

Please verify that the moxzglue tests are part of a test suite that is part of the scheduled codecoverage run.

Here is some test code

> https://dxr.mozilla.org/mozilla-central/source/mozglue/tests/TestPrintf.cpp?q=mozglue%2Ftests%2FTestPrintf.cpp&redirect_type=direct

Here is the file it should cover

> https://codecov.io/gh/marco-c/gecko-dev/src/master/mozglue/misc/Printf.cpp
It's coverage is collected in the CPP test suite:  https://treeherder.mozilla.org/#/jobs?repo=mozilla-central&revision=8a990794c2ee923ccd839750912d10ff3a690a2a&filter-searchStr=ccov&selectedJob=106112913

Here's part of the live_backing.log file:
[task 2017-06-10T18:56:23.724103Z] 18:56:23     INFO -  testPrivateGCThingValue
[task 2017-06-10T18:56:23.724321Z] 18:56:23     INFO -  TEST-PASS | testPrivateGCThingValue | ok
[task 2017-06-10T18:56:23.724548Z] 18:56:23     INFO -  testPrintf
[task 2017-06-10T18:56:23.724765Z] 18:56:23     INFO -  TEST-PASS | testPrintf | ok
[task 2017-06-10T18:56:23.724975Z] 18:56:23     INFO -  test_PreserveJitCode
[task 2017-06-10T18:56:23.725188Z] 18:56:23     INFO -  TEST-PASS | test_PreserveJitCode | ok
Ah, wrong TestPrintf...
I see that TestPrintf uses CppUnitTests instead of GeckoCppUnitTests here at [1]. And that 'ShowSSEConfig' is running in CPP. 

Another thing I found is that we might be losing the test at [2] because of the lower() function, but I'll have to look into this some more.

[1]: https://dxr.mozilla.org/mozilla-central/source/mozglue/tests/moz.build#9
[2]: https://dxr.mozilla.org/mozilla-central/source/python/mozbuild/mozbuild/util.py#445
Depends on: 1379526
Blocks: 1301170
See bug 1379526 comment 1 and 2.
Summary: Ensure mozglue is scheduled for nightly coverage → TestPrintf is not executed in coverage builds
No longer depends on: 1379526
Duplicate of this bug: 1379526
I believe this test is not getting executed in any build, at least I can't see any reference to TestPrintf in the logs of a linux64-debug build: https://treeherder.mozilla.org/logviewer.html#?job_id=113383388&repo=mozilla-central.

I can see ShowSSEConfig, but I can't see TestPrintf (note there is a "testPrintf", but that one is a different test from jsapi-tests).
See Also: → 1334276
I think we need to add the file to https://dxr.mozilla.org/mozilla-central/source/testing/cppunittest.ini.
Assignee: nobody → mcastelluccio
Status: NEW → ASSIGNED
Posted patch PatchSplinter Review
Attachment #8885470 - Flags: review?(mh+mozilla)
Summary: TestPrintf is not executed in coverage builds → TestPrintf is not executed on automation
Attachment #8885470 - Flags: review?(mh+mozilla) → review+
Keywords: checkin-needed
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/5a2528017eae
Add TestPrintf to cppunittest.ini to make it execute on automation. r=glandium
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/5a2528017eae
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla56
You need to log in before you can comment on or make changes to this bug.