Closed Bug 1371977 Opened 4 years ago Closed 4 years ago

WebRenderPaintedLayerBlob respects mValidRegion but does not update it

Categories

(Core :: Graphics: WebRender, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1373863

People

(Reporter: mstange, Unassigned)

References

Details

There is this line in WebRenderPaintedLayerBlob::RenderLayer:

> regionToPaint.Sub(mVisibleRegion.ToUnknownRegion(), mValidRegion);

Are we intentionally excluding the current valid region from the region to paint? Or do we always want to paint the whole layer?
We're currently not updating mValidRegion to include the drawn region after at the end of RenderLayer(), so it's possible that mValidRegion is just always empty here. In that case, subtracting it from the visible region won't make a difference. But it's still confusing.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1373863
You need to log in before you can comment on or make changes to this bug.