Back menu doesn't dismiss when mouse held down

VERIFIED DUPLICATE of bug 102330

Status

()

VERIFIED DUPLICATE of bug 102330
17 years ago
10 years ago

People

(Reporter: RahmCoff+moz, Assigned: hyatt)

Tracking

Trunk
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
Steps to reproduce:

1. MouseDown on the back menu widget.
2. MouseUp on a previous page.

Expected behavour:

Window loads previous page and the menu is dismissed.

Actual bbehavour:

Window loads previous page and the menu remains. All of the buttons and links
work and the window can be moved, but that damn menu stays there. It's even on
top of other applications.
(Reporter)

Comment 1

17 years ago
Created attachment 78995 [details]
Picture showing menu still there even after the window moved

This shows that the menu is still there after having already loaded a previous
page, but the browser window has been moved too.

Comment 2

17 years ago
WorksForMe using FizzillaCFM/2002041712 (RC1).

Peter, can you still reproduce this problem using a current build?
(Reporter)

Comment 3

17 years ago
Working now for me too. I haden't tried it since picking up RC1.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
(Reporter)

Comment 4

17 years ago
This bug has regressed with RC2. 
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---
(Reporter)

Comment 5

17 years ago
New steps to reproduce:

1. Click on back menu triangle and hold down the mouse button.
2. Keep it there for about a second.
3. Move down and release mouse in menu.

This is my usual behavour when using the back menu. 

Comment 6

17 years ago
Was able to reproduce using RC2 by:

1) MouseDown on Back triangle
2) MouseUp without moving pointer onto a History item

Pop-up menu did not dismiss.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 7

17 years ago
The behavour you're describing is covered by bug 101472. What makes this bug
different is that when you select an item on the other pop-up menus, they are
dismissed.

Comment 8

17 years ago
Confirmed. Peter, I was able to reproduce the the behavior you're describing
using RC2.

Comment 9

17 years ago
*** Bug 146301 has been marked as a duplicate of this bug. ***

Comment 10

17 years ago
This bug appears to be resolved with RC3
*** Bug 146301 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 12

17 years ago
I'm still seeing it with RC3.
(Reporter)

Comment 13

17 years ago
I think I figured out what's going on. It's making two menus when you hold the
button down on the triangle. The first one is dismissed when you select an item,
but the second one remains. I whish I had a screen shot to how you how I found out.

Comment 14

17 years ago
There are two bugs here.
(1) When your computer is trying to do lots of stuff at once, Mozilla thinks that
    a click is a click-and-hold. That's bug 117589.
(2) When you do a click-and-hold on the Back menubutton, one copy of the Back menu 
    opens because you clicked on the menubutton, and another copy of the menu
    opens because you clicked-and-held on the Back button (which includes the
    menubutton). That's bug 102330. Then when you choose an item from the
    frontmost copy of the menu, the other copy stays behind.

*** This bug has been marked as a duplicate of 102330 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → DUPLICATE

Comment 15

16 years ago
mass duplicate verifications . For filtering purposes, pls use keywd
"massdupverification"

Status: RESOLVED → VERIFIED

Updated

10 years ago
Component: XP Toolkit/Widgets: Menus → XUL
QA Contact: shrir → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.