Closed Bug 1372045 Opened 3 years ago Closed 2 years ago

'Hide connection details' tooltip for switching back to main view in Identity popup/doorhange not shown

Categories

(Firefox :: Site Identity, defect, P5)

defect

Tracking

()

RESOLVED INVALID
Tracking Status
firefox54 --- unaffected
firefox55 --- fix-optional
firefox56 --- fix-optional

People

(Reporter: aryx, Unassigned)

References

Details

Firefox Nightly 55.0a1 20170611030208 on Windows 8.1

Bug 1335016 implemented tooltips for the button which opens and closes the connection details subview in the identity doorhanger. The tooltip to hide the subview is not shown.

Steps to reproduce:
1. Open a page, e.g. https://support.mozilla.org/en-US/
2. In the URL bar on the left, click on the circle with the "i".
3. Next to "Mozilla Foundation", click the ">" (or "<" if you use an RTL language).
4. Move the mouse over the "<".

Actual result:
No tooltip shown.

Expected result:
Tooltip "Hide connection details" shown:
https://hg.mozilla.org/mozilla-central/annotate/8a990794c2ee923ccd839750912d10ff3a690a2a/browser/base/content/browser.js#l7597

Setting a conditional breakpoint in handleEvent shows that tooltip has the correct text. Trying to inspect the identity doorhanger with the Browser Toolbox makes the Toolbox unresponsive.
This is quite strange. I can confirm, also by inspecting in the toolbox, that the item has the correct tooltip. When I originally implemented this I'm 100% sure it showed the tooltip on all platforms.

There's been a lot of work going on in panels recently, so I'm needinfo'ing Mike on the off chance that he has an idea what could have caused this.

In any case, I suspect that this is not actually relevant for a11y since the attribute is correctly set and that should still get picked up by a screen reader (someone correct me if I'm wrong). If that's true then we can put this on lowest priority, IMO.
Flags: needinfo?(mdeboer)
Priority: -- → P2
(In reply to Johann Hofmann [:johannh] from comment #1)
> In any case, I suspect that this is not actually relevant for a11y since the
> attribute is correctly set and that should still get picked up by a screen
> reader (someone correct me if I'm wrong). If that's true then we can put
> this on lowest priority, IMO.

Yes this is true.
It might be that another element is overlaying the expander now with the new resizing architecture that Paolo implemented. Paolo, do you know if that might be the case?
Flags: needinfo?(mdeboer) → needinfo?(paolo.mozmail)
There's always been a clickCapturer element over the left side of the panel, regardless of the resizing architecture. Maybe something changed in how tooltips are handled when there are overlaying elements? There is also the possibility that this tooltip was indeed not showing when this originally landed...
Flags: needinfo?(paolo.mozmail)
I'm actually not sure if this was ever showing anymore either...

Since it's technically a bug I'll P5 this, but I would recommend we don't spend too much time worrying about it.
Side note: this will be different *again* once the identity panel is moved to use Photon views instead. Fun!
Made irrelevant by bug 1409301.
Status: NEW → RESOLVED
Closed: 2 years ago
Depends on: 1409301
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.