[DateTimeInput] RTL : The right/left arrows don't work for some segments

RESOLVED INVALID

Status

()

Core
Layout: Form Controls
RESOLVED INVALID
4 months ago
2 months ago

People

(Reporter: roxana.leitan@softvision.ro, Unassigned)

Tracking

(Blocks: 1 bug)

55 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 months ago
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:55.0) Gecko/20100101 Firefox/55.0
Build ID:20170611030208

[Affected versions]:
Nightly 55.0a1

[Affected platforms]:
All platforms: Ubuntu 16.04, Windows 10, Mac OS X 10.12

[Steps to reproduce]:
1.Launch Nightly 55.0a1 AR build with a new profile
2.Open https://www.w3schools.com/code/tryit.asp?filename=FEJ73OTUHO7J and click "Run"
3.Move focus to minutes segment
4.Press left arrow key

[Expected result]:
The focus should be moved to AM/PM segment

[Actual result]:
The focus stays on minutes segment

[Note]:
Reproducible also for AM/PM segment with right arrow key
triage: likely an expected behavior, suggest to compare with "tab" behavior.
on Windows the behavior (tab and left/right) is the same, so we can close this if on Mac it's also the case.

Comment 3

3 months ago
(In reply to Wesley Huang [:wesley_huang] (EPM) (NI me) from comment #2)
> on Windows the behavior (tab and left/right) is the same, so we can close
> this if on Mac it's also the case.

Verified on Mac OSX 10.12 with Latest Nightly AR 57.0a1 Build 20170802100302 and it can be observed the following behaviour:
- After focusing mouse on the minutes segment and pressing left arrow key, nothing happens (minutes segment remaining focused)
- After focusing mouse on the minutes segment and pressing Tab key, the focus moves to Am/Pm segment, and then by pressing again, the hour segment is focused
The behaviour on Mac and Windows is different, maybe this should taken under investigation, considering the inconsistency between OSes.
Flags: needinfo?(whuang)
(In reply to Deac Alin from comment #3)
> (In reply to Wesley Huang [:wesley_huang] (EPM) (NI me) from comment #2)
> > on Windows the behavior (tab and left/right) is the same, so we can close
> > this if on Mac it's also the case.
> 
> Verified on Mac OSX 10.12 with Latest Nightly AR 57.0a1 Build 20170802100302
> and it can be observed the following behaviour:
> - After focusing mouse on the minutes segment and pressing left arrow key,
> nothing happens (minutes segment remaining focused)
> - After focusing mouse on the minutes segment and pressing Tab key, the
> focus moves to Am/Pm segment, and then by pressing again, the hour segment
> is focused
> The behaviour on Mac and Windows is different, maybe this should taken under
> investigation, considering the inconsistency between OSes.

Hi Deac,

First, I'd like to clarify that in AR build, the format is:

  AM/PM hh:mm

I tested on both Mac and Windows, when tabbing into the input field, the hour segment is first focused. Pressing the left arrow key does nothing, and pressing the right key, focus goes to the minute segment and then to the AM/PM segment. This is the same is using the TAB key. When focus is on AM/PM field, pressing the right key does nothing, and presseing TAB, focus moves away from the input field.
Is this the bahavior that you get?
Flags: needinfo?(alin.deac)

Comment 5

2 months ago
(In reply to Jessica Jong [:jessica] from comment #4)

>   AM/PM hh:mm

> I tested on both Mac and Windows, when tabbing into the input field, the
> hour segment is first focused. Pressing the left arrow key does nothing, and
> pressing the right key, focus goes to the minute segment and then to the
> AM/PM segment. This is the same is using the TAB key. When focus is on AM/PM
> field, pressing the right key does nothing, and presseing TAB, focus moves
> away from the input field.
> Is this the bahavior that you get?


Hi Jessica,

Yes this is the behaviour that I get. Is this intended?
My concern was regarding the Expected behaviour from the issue description at Step 4 (after pressing the left key)
Thank you
Flags: needinfo?(alin.deac)
(In reply to Deac Alin from comment #5)
> (In reply to Jessica Jong [:jessica] from comment #4)
> 
> >   AM/PM hh:mm
> 
> > I tested on both Mac and Windows, when tabbing into the input field, the
> > hour segment is first focused. Pressing the left arrow key does nothing, and
> > pressing the right key, focus goes to the minute segment and then to the
> > AM/PM segment. This is the same is using the TAB key. When focus is on AM/PM
> > field, pressing the right key does nothing, and presseing TAB, focus moves
> > away from the input field.
> > Is this the bahavior that you get?
> 
> 
> Hi Jessica,
> 
> Yes this is the behaviour that I get. Is this intended?
> My concern was regarding the Expected behaviour from the issue description
> at Step 4 (after pressing the left key)
> Thank you

Oh, sorry, we have discussed this in our regular meeting. See Comment 1 and 2, we should compare with the tab order instead, that means, pressing right key should be the same as tabbing, and pressing left key should be the opposite of tabbing. If it works as mentioned, then it's the expected bahvior.

Comment 7

2 months ago
Thank you for clarifying this. Based on the latest comment, works as expected. Closing this issue. Thank you.
Status: NEW → RESOLVED
Last Resolved: 2 months ago
Resolution: --- → INVALID
Flags: needinfo?(whuang)
You need to log in before you can comment on or make changes to this bug.