The search suggestions hint is not smooth enough when animating

VERIFIED FIXED in Firefox 55

Status

()

defect
P3
normal
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: simona.marcu, Assigned: Paolo)

Tracking

55 Branch
Firefox 56
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox54 unaffected, firefox55 verified, firefox56 verified)

Details

(Whiteboard: [fxsearch])

Attachments

(2 attachments)

Posted video hintIssue.mp4
[Affected versions]:
- Nightly 55.0a1
 
[Affected platforms]:
- All
 
[Steps to reproduce]:
1. Launch Nightly with a new profile
2. Focus the Awesome bar by mouse click
 
[Expected result]:
- The search suggestions hint should smoothly animate.
 
[Actual result]:
- The search suggestions hint is not smooth enough when animating. Please see the screencast for more details.
 
[Regression range]:
- I'll investigate as soon as possible and post back the results.
 
[Additional notes]:
- This issue is not reproducible on a build from 24th of May (Build ID: 20170524030204)
Component: Search → Location Bar
Whiteboard: [fxsearch]
Priority: -- → P3
P3 for now and we will reconsider once the cause is known.
Using the mozregression tool I got to the following commit message:
Bug 1368437 - Search suggestions hint doesn't scale well with the window size. r=past

Pushlog:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=b609d94a575a85e6228f751893d6324683510670&tochange=d697cd9de8d38e38292b79834c8889c0eb05a3cb
It may be the display flex, but without it we regress bug 1368437. Unfortunately having all the requirements for this notification (shrinking behavior, animations, l10n, a11y, rtl) takes a lot of time, so either we drop some requirements or we'll just spend lots of resources for simple polish issues like this one. Atm I don't have time to play with the css rules to see if there's a way to improve perf without losing any of those requirements.
I agree with Marco that we shouldn't worry too much about this. What the hint is about is unclear anyways, the icons are used inconsistently, and the text animation is meant to look like someone typing, but it doesn't convey this effect anyways.

By adding a small blank space to the end of the text, we can make the animation look faster. Also, the issues with the animation wouldn't be noticeable in that space.
Comment on attachment 8877999 [details]
Bug 1372242 - The search suggestions hint is not smooth enough when animating.

https://reviewboard.mozilla.org/r/149410/#review154084

This looks great, thank you!
Attachment #8877999 - Flags: review?(mak77) → review+
note: since this is very simple, we should probably uplift to 55.
Pushed by paolo.mozmail@amadzone.org:
https://hg.mozilla.org/integration/mozilla-inbound/rev/b14f6dbb544b
The search suggestions hint is not smooth enough when animating. r=mak
https://hg.mozilla.org/mozilla-central/rev/b14f6dbb544b
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 56
I have reproduced this bug with Nightly 56.0a1 (2017-06-12) on Ubuntu 16.04, 64 bit!

The fix is now verified on Latest Nightly.

Build ID 	20170617100144
User Agent 	Mozilla/5.0 (X11; Linux x86_64; rv:56.0) Gecko/20100101 Firefox/56.0
QA Whiteboard: [bugday-20170614]
I have successfully reproduced this bug with Nightly 55.0a1 (2017-06-12)  on windows 10(32bit)

this bug is verified fix with  latest Nightly 56.0a1 (2017-06-17) (32-bit)

Build ID: 20170617030206
Mozilla/5.0 (Windows NT 10.0; rv:56.0) Gecko/20100101 Firefox/56.0
As per Comment 10 and Comment 11, I am marking this bug as verified fixed.
Status: RESOLVED → VERIFIED
Comment on attachment 8877999 [details]
Bug 1372242 - The search suggestions hint is not smooth enough when animating.

Approval Request Comment
[Feature/Bug causing the regression]: new search suggestions in location bar hint
[User impact if declined]: animation looking janky
[Is this code covered by automated tests?]: no
[Has the fix been verified in Nightly?]: yes
[Needs manual test from QE? If yes, steps to reproduce]: yes
[List of other uplifts needed for the feature/fix]: none
[Is the change risky?]: no
[Why is the change risky/not risky?]: simple and targeted css fix
[String changes made/needed]: none
Attachment #8877999 - Flags: approval-mozilla-beta?
Assignee: nobody → paolo.mozmail
Comment on attachment 8877999 [details]
Bug 1372242 - The search suggestions hint is not smooth enough when animating.

looks harmless enough.  beta55+, should be in 55.0b3
Attachment #8877999 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Verified as fixed using the latest Nightly 56.0a1 (Build ID: 20170618030207) on Windows 7 x64, Windows 10 x64, Ubuntu 16.04 and Mac OS X 10.12.
Flags: qe-verify+
Verified as fixed using the latest Firefox 55 beta 3 (Build ID: 20170619071723) on Windows 10 x64, Ubuntu 16.04 x64 and Mac OS X 10.12.
Flags: qe-verify+
I reproduced this issue using Fx 56.0a1 (build ID:20170612091112) on Windows 10 x64.
I can confirm this issue is fixed, I verified using Fx55.0b3, on Windows 10 x64, macOS X 10.12.5 and Ubuntu 14.04 LTS x64.

Cheers!
You need to log in before you can comment on or make changes to this bug.