If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Windows 64-bit opt xpcshell permafailing on Beta since the uplift

RESOLVED FIXED in Firefox 55

Status

Testing
XPCShell Harness
--
blocker
RESOLVED FIXED
3 months ago
2 months ago

People

(Reporter: RyanVM, Assigned: junior)

Tracking

(Blocks: 1 bug)

unspecified
mozilla56
x86_64
Windows
Points:
---

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox54 unaffected, firefox55 fixed, firefox56 fixed)

Details

(Reporter)

Description

3 months ago
Windows 64-bit opt xpcshell is currently permafailing since the uplift with harness timeouts like the log below:
https://treeherder.mozilla.org/logviewer.html#?job_id=106399916&repo=mozilla-beta&lineNumber=6234

There's a common theme of lots of rmtree() failures and eventually a Python "thread.error: can't start new thread" error followed by the harness timing out and being force killed.

Not sure what's at fault at this point, so filing under the XPCShell harness for now. I think this needs to block gtb for 55b1, though, since it's preventing us from getting any win64 xpcshell results.

Wes did a set of uplift simulations early Sunday morning and this issue wasn't visible then, so there's at least a decent possibility that this was a recent regression. Below is a pushlog between the last set of simulations and what was eventually uplifted to Beta:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=799d43edb324&tochange=f9605772a0c9

Bug 1371548 looks like a possibility, but I'm not sure how that code interacts with code run during xpcshell. It's at least worth a Try push, though. As Ehsan pointed out on IRC, the line below looks like something that could be broken on Win64:
https://hg.mozilla.org/mozilla-central/rev/f7987c98de3e#l1.12
(Reporter)

Comment 1

3 months ago
Try push of current Beta tip:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=854963773a811e828babdbb0946bb51598f23bfe

Try push of current Beta tip and bug 1371548 backed out:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=737c09d206997f2467b23e3405c6578eb284a7a7
(In reply to Ryan VanderMeulen [:RyanVM] from comment #0)
> Bug 1371548 looks like a possibility, but I'm not sure how that code
> interacts with code run during xpcshell. It's at least worth a Try push,
> though. As Ehsan pointed out on IRC, the line below looks like something
> that could be broken on Win64:
> https://hg.mozilla.org/mozilla-central/rev/f7987c98de3e#l1.12

Nope. The only way that code could possibly be relevant is if we were seeing the failure when running subprocess tests. But even if that code didn't work on win64 (which, incidentally, is the platform it was written for and tested on), we'd just fall back to the old error that change was intended to fix.
(Reporter)

Comment 3

3 months ago
Turns out this was permafail from bug 1158387 that got misstarred and eventually merged around just before the uplift to Beta. FML.
(Reporter)

Comment 4

3 months ago
https://hg.mozilla.org/releases/mozilla-beta/rev/538e29345b39
Status: NEW → RESOLVED
Last Resolved: 3 months ago
status-firefox55: affected → fixed
status-firefox56: affected → fixed
tracking-firefox55: ? → ---
tracking-firefox56: ? → ---
Resolution: --- → FIXED
(Reporter)

Updated

2 months ago
Assignee: nobody → juhsu
Blocks: 1158387
Target Milestone: --- → mozilla56
You need to log in before you can comment on or make changes to this bug.