CRM/Email Marketing Request: View Source 2017 Announcement

RESOLVED FIXED

Status

RESOLVED FIXED
a year ago
a year ago

People

(Reporter: dvincent, Unassigned)

Tracking

(Depends on: 1 bug)

Details

Attachments

(1 attachment)

(Reporter)

Description

a year ago
>> Mozilla Team/Department
Developer Outreach
>> What kind of relationships are you looking to develop?
Not develop, per se, but build upon. We want to build upon our existing View Source developer community and create a new event.
>> How will you nurture these relationships?
By creating a really amazing developer event.
>> How will success be measured?
# of opens
# of retained subscribers
# of clicks
# of ticket sales
>> What is the risk to not doing this?
We do not effectively communicate with our community and we don't sell tickets to people who would be interested in going
>> What's the timeline for launch?
Late July, early August

Comment 1

a year ago
Thanks, Danielle!

I just invited you to the weekly LCM intake mtg. This Monday, 6/19 at 9:30am PT in Michele's room.

See you there to talk next steps,

Jess

Comment 2

a year ago
Thanks for meeting, Danielle!

Notes are here:
https://docs.google.com/document/d/1hB-PHqLmWhjsoxmbP5Y-Tt0R6YqXoiy9cpmDcYrVhSA/edit#heading=h.ytmurn3um4yl

We're working on building out this user story in our backlog. We'll keep you posted when it's prioritized.

Thanks!

Comment 3

a year ago
Created attachment 8881834 [details]
Mozilla Event_Webinar Campaign Flow Blueprint DRAFT FOR REVIEW_INPUT(1).pdf

Attached is the Events blueprint we'll build out for View Source 2017 communications.
(Reporter)

Comment 4

a year ago
Funny! I just added "view source event attendees" and "dev event emails" to our outbound communication whiteboard. ;)

Updated

a year ago
Duplicate of this bug: 1390308

Comment 6

a year ago
Hey Danielle!

Question before we sync up on Monday during the reg LCM intake mtg:

Do you have content that you've created yet for these email sends? If so, please link to the doc here.


Here are the notes from our LCM intake (linked in #c2 above):

- Send to all people who subscribed to hear about View Source (special announcement)
-- Ask for help to set up audience segmentation report
--- 1) Subscribed to View Source or Dev Events;
--- 2) If attended View Source 2016, can send transactional update (will need special copy);
- Opportunity to build out “Event” Journey template (#c3)

- How many emails talking about event total?
- Need to figure out how to exclude people who have RSVPed. TiTo tool?
- Part of ongoing dev news content
Flags: needinfo?(dvincent)
(Reporter)

Comment 7

a year ago
Here's the email overview doc: https://docs.google.com/a/mozilla.com/document/d/15wnk-HiSd3lX29W6pApnoFwov2yBiD5sO5USxax-0L4/edit?usp=sharing

We are putting dates in here and revising these emails on Thursday, August 17, so the spreadsheet will be updated by the time we meet on Monday

That doc will contain all the links to content as we write them.
(Reporter)

Comment 8

a year ago
(I am keeping this as "needs info" for now)
(Reporter)

Comment 9

a year ago
Email schedule doc has been updated with intended VS email schedule:
https://docs.google.com/a/mozilla.com/document/d/15wnk-HiSd3lX29W6pApnoFwov2yBiD5sO5USxax-0L4/edit?usp=sharing
Flags: needinfo?(dvincent)

Comment 10

a year ago
Hey Danielle!

I've added suggested audiences for your outreach emails to your VS 2017 Email Communications doc:
https://docs.google.com/document/d/15wnk-HiSd3lX29W6pApnoFwov2yBiD5sO5USxax-0L4/edit


Audiences have been set up in Marketing Cloud (in the same place as your regular sending Dev News Data extension). Please refresh these Data Extensions before you send:


Data Extensions > DEV MARKETING


MoCo_GLOBAL_DEV_2017_EVENT_HTML_View-Source-Dev-Events_ALL_EN_SEG_
View Source Global or NA, or Dev Events subscribers
count: 1,327

MoCo_GLOBAL_DEV_2017_EVENT_HTML_Dev-Events_ALL_EN_SEG_
Dev Events subscribers
count: 1,094

MoCo_GLOBAL_DEV_2017_EVENT_HTML_View-Source_ALL_EN_SEG_
View Source Global only subscribers
count: 1,064

MoCo_NA_DEV_2017_EVENT_HTML_View-Source_ALL_EN_SEG_
View Source NA only subscribers
count: 626


Reminder: If someone opts into View Source Global or NA, they are also subscribed to Dev Events. Dev Events also includes people who opt-ed in from GDC.


Please let us know if you plan on sending a transactional email via TiTo to 2016 VS attendees. This content will need to be reviewed by LCM & Legal.


Otherwise, you've got what you need to set up the first email(s) using our standard promotional template and send:
https://docs.google.com/presentation/d/1BDm00skl53HAJzI9wyVAfVPmpTQxp-1fq1ULP6SYTFA/edit#slide=id.g1e06dc13ef_2_55


We'll need to sync up on the follow up announcement emails if we want to exclude RSVPs out of the TiTo system. Please let us know if this is the plan and the timing around it so we can prioritize this story in our backlog.


Holler at us if you have questions.

Please keep us in the loop as you send proofs and add the email(s) to the email launch calendar.

Thanks!
(Reporter)

Comment 11

a year ago
sent! 9/19 to MoCo_GLOBAL_DEV_2017_EVENT_HTML_View-Source-Dev-Events_ALL_EN_SEG_ (1,324 subscribers)

We're doing the ti.to 2016 View Source list October 2, 2017

Comment 12

a year ago
Excellent! Thanks, Danielle! The send looked lovely.

Legal will need to review the ti.to 2016 View Source list copy before you send. The sooner you can get that content together and file a Legal bug: https://bugzilla.mozilla.org/enter_bug.cgi?product=Legal, the better. (It'll take a week for them to review.)

Updated

a year ago
Depends on: 1404466

Comment 13

a year ago
Update: Just got copy from Danielle and filed the Legal bug for review: Bug 1404466


Once this email is cleared by Legal, this bug can be resolved as the other emails to be sent to View Source potential peeps (#c10) can be handled 100% by Danielle.


Thanks, Danielle!
(Reporter)

Comment 14

a year ago
Bug 140446 has been closed, and View Source emails are all safely within my hands. I'm closing this bug, and we're all going to take a nap.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.