Better naming for nsInputStreamReadyEvent

RESOLVED FIXED in Firefox 56

Status

()

Core
XPCOM
RESOLVED FIXED
7 months ago
5 months ago

People

(Reporter: billm, Assigned: billm)

Tracking

unspecified
mozilla56
Points:
---

Firefox Tracking Flags

(firefox56 fixed)

Details

Attachments

(1 attachment)

Created attachment 8876936 [details] [diff] [review]
patch

The nsInputStreamReadyEvent shows up a lot in telemetry. There are a lot of different ways this runnable is used. I would like to use more precise names so that we can figure out which uses are the most common. That will make it easier to decide which ones to prioritize for labeling.

Eric, I know you haven't been reviewing these patches, but I'm trying to lighten the load on Nathan. I think the patch is pretty straightforward, but let me know if you need more context. https://wiki.mozilla.org/Quantum/DOM has some background.
Attachment #8876936 - Flags: review?(erahm)
Comment on attachment 8876936 [details] [diff] [review]
patch

Review of attachment 8876936 [details] [diff] [review]:
-----------------------------------------------------------------

r=me. The amount of copy and paste going on with those imgEncoders is kind of sad but obviously not your fault! Feel free to send other reviews my way.
Attachment #8876936 - Flags: review?(erahm) → review+

Comment 2

7 months ago
Pushed by wmccloskey@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/e8a63038d787
More detailed names for nsInputStreamReadyEvent (r=erahm)

Comment 4

7 months ago
Pushed by wmccloskey@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/45b5cadadc22
More detailed names for nsInputStreamReadyEvent (r=erahm)
Flags: needinfo?(wmccloskey)

Comment 5

7 months ago
I had to back this out because it was conflicting with my backout of bug 1371699. https://hg.mozilla.org/integration/mozilla-inbound/rev/d14e2e6cae0e185a8c04b7b906c8784c6916a614
Flags: needinfo?(wmccloskey)

Comment 6

7 months ago
Pushed by wmccloskey@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/dfee29c06556
More detailed names for nsInputStreamReadyEvent (r=erahm)
https://hg.mozilla.org/mozilla-central/rev/dfee29c06556
Status: NEW → RESOLVED
Last Resolved: 7 months ago
status-firefox56: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla56
Flags: needinfo?(wmccloskey)
Duplicate of this bug: 1352174
You need to log in before you can comment on or make changes to this bug.