stylo: More thoroughly test the performance of the style invalidation added in bug 1368240

RESOLVED DUPLICATE of bug 1422010

Status

()

Core
CSS Parsing and Computation
P4
normal
RESOLVED DUPLICATE of bug 1422010
10 months ago
2 months ago

People

(Reporter: emilio, Assigned: emilio)

Tracking

unspecified
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr52 wontfix, firefox55 wontfix, firefox56 wontfix, firefox57 wontfix)

Details

(Assignee)

Description

10 months ago
In bug 1368240 I added some invalidation that makes us restyle a lot less in cases when there are combinators.

We can only test whether we've have or haven't restyled right now, but it'd be nice to add an API to get the number of elements restyled in order to test it more precisely.

Updated

10 months ago
Priority: -- → P4

Comment 1

10 months ago
Would it be easy to just add a style-perf test [1] for this?

[1] https://github.com/heycam/style-perf-tests
Flags: needinfo?(emilio+bugs)
(Assignee)

Comment 2

10 months ago
Yes, that's the plan, but to prove correctness we may also want to verify we've restyled more exactly.
Flags: needinfo?(emilio+bugs)

Comment 3

10 months ago
Ok, over to emilio.
Assignee: nobody → emilio+bugs
status-firefox55: --- → wontfix
status-firefox56: --- → wontfix
status-firefox57: --- → affected
status-firefox-esr52: --- → wontfix
status-firefox57=wontfix unless someone thinks this bug should block 57
status-firefox57: affected → wontfix
(Assignee)

Updated

5 months ago
Depends on: 1422010
(Assignee)

Updated

2 months ago
Status: NEW → RESOLVED
Last Resolved: 2 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1422010
You need to log in before you can comment on or make changes to this bug.