[TSF] Investigate if it's possible to cache compartment of GUID_COMPARTMENT_KEYBOARD_OPENCLOSE

RESOLVED FIXED in Firefox 56

Status

()

RESOLVED FIXED
a year ago
a year ago

People

(Reporter: masayuki, Assigned: masayuki)

Tracking

({inputmethod})

Trunk
mozilla56
All
Windows
inputmethod
Points:
---

Firefox Tracking Flags

(firefox56 fixed)

Details

(Whiteboard: tpi:+)

Attachments

(1 attachment)

The compartment of GUID_COMPARTMENT_KEYBOARD_OPENCLOSE may be retrieved a lot (perhaps, every focus change and more). It needs a QI and a virtual call. Additionally, GetCompartment() sometimes appears in some crash reports which are caused by bugs of TSF or TIP. So, if it's possible to cache the compartment, we can reduce running cost and/or number of crashes.
Comment hidden (mozreview-request)

Comment 4

a year ago
mozreview-review
Comment on attachment 8877428 [details]
Bug 1372560 TSFTextStore should cache compartment for keyboard open/close

https://reviewboard.mozilla.org/r/148840/#review153432
Attachment #8877428 - Flags: review?(m_kato) → review+

Comment 5

a year ago
Pushed by masayuki@d-toybox.com:
https://hg.mozilla.org/integration/autoland/rev/c4121a9a2281
TSFTextStore should cache compartment for keyboard open/close r=m_kato

Updated

a year ago
Whiteboard: tpi:+
https://hg.mozilla.org/mozilla-central/rev/c4121a9a2281
Status: ASSIGNED → RESOLVED
Last Resolved: a year ago
status-firefox56: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla56
You need to log in before you can comment on or make changes to this bug.