visual pauses playing video on twitter

RESOLVED FIXED in Firefox 55

Status

()

RESOLVED FIXED
a year ago
a year ago

People

(Reporter: bkelly, Assigned: jya)

Tracking

({regression})

55 Branch
mozilla56
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox54 unaffected, firefox55- fixed, firefox56+ fixed)

Details

STR:

1. Open nightly.  I used 56.0a1 (2017-06-13) (64-bit).
2. Go to https://twitter.com/firefox/status/874758953187418112
3. Play the video.
4. Observe that the audio is continuous, but the video has visual pauses of about 1 second in duration.

I took a profile, but don't see anything on the main threads that would explain this:

https://perfht.ml/2tjA99a

Is there a video decode thread or something that we can profile?

This reproduces on nightly for me, but not release FF54.
[Tracking Requested - why for this release]: ugly video stuttering

INFO: Last good revision: 3ad1b460540d2a6eda0011805457d9701d113f26
INFO: First bad revision: d0fea6559ec29e78eeb2d353975720d18a592b25
INFO: Pushlog:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=3ad1b460540d2a6eda0011805457d9701d113f26&tochange=d0fea6559ec29e78eeb2d353975720d18a592b25

30:36.22 INFO: Looks like the following bug has the  changes which introduced the regression:
https://bugzilla.mozilla.org/show_bug.cgi?id=1313398

I'm on Win10 FWIW.
Blocks: 1313398
Has Regression Range: --- → yes
Has STR: --- → yes
status-firefox54: --- → unaffected
status-firefox55: --- → affected
status-firefox56: --- → affected
status-firefox-esr52: --- → unaffected
tracking-firefox55: --- → ?
tracking-firefox56: --- → ?
Flags: needinfo?(jyavenard)
Keywords: regression
Version: unspecified → 55 Branch
Forgot to mention that I've reproduced this on Beta tip as well.
(Reporter)

Comment 3

a year ago
Seems like a functional regression and not a qf perf issue.
Whiteboard: [qf]
tracking this regression for 55/56
tracking-firefox55: ? → +
tracking-firefox56: ? → +
(Reporter)

Updated

a year ago
See Also: → bug 1373827
(Assignee)

Comment 5

a year ago
I could reproduce it yesterday, but no longer... it's smooth here (windows 10)
(Assignee)

Comment 6

a year ago
The issue appears to be with the low res version of the video.

I put a copy there:
https://people-mozilla.org/~jyavenard/mediatest/Firefox%20%F0%9F%A6%8A%F0%9F%8C%8D%20-%20What's%20multi-process%20Firefox-1.mp4

There's something wrong with this video. It plays just as badly in chrome. You can even see the frames being displayed out of order there.

I don't believe the issue is with what we're doing in. the video is poorly encoded.

It used to work out of sheer luck..
Flags: needinfo?(jyavenard)
(Assignee)

Comment 7

a year ago
In Edge the video shows small pauses too.
(Assignee)

Comment 8

a year ago
I'm assuming when the first issue was reported the video was actually even more broken.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → WORKSFORME
(Assignee)

Comment 9

a year ago
The videos have changed SPS/PPS nal in-band and every few frames... this is why bug 1313398 shows a problem... I do believe this file is invalid just based on how other browsers are playing it.
(Assignee)

Updated

a year ago
See Also: → bug 1374068
(Reporter)

Comment 10

a year ago
I'm sorry, but I only see pauses in firefox nightly and beta on this video.  It plays smoothly in chrome and edge on my machine.  It also plays smoothly in firefox release.

Are you opening the twitter link in each browser or did you download the video to play it in each browser?  Maybe we are getting served a different version of the video?
Status: RESOLVED → REOPENED
Flags: needinfo?(jyavenard)
Resolution: WORKSFORME → ---
(Assignee)

Comment 11

a year ago
(In reply to Ben Kelly [reviewing, but slowly][:bkelly] from comment #10)
> I'm sorry, but I only see pauses in firefox nightly and beta on this video. 
> It plays smoothly in chrome and edge on my machine.  It also plays smoothly
> in firefox release.
> 
> Are you opening the twitter link in each browser or did you download the
> video to play it in each browser?  Maybe we are getting served a different
> version of the video?

those will be fixed following bug 1374068

BTW, the videos you said give you problems, play awfully in both Edge and Chrome. The only videos that would show problems are invalid to start with.
Status: REOPENED → RESOLVED
Last Resolved: a year agoa year ago
Flags: needinfo?(jyavenard)
Resolution: --- → FIXED
(Assignee)

Comment 12

a year ago
(In reply to Ben Kelly [reviewing, but slowly][:bkelly] from comment #10)
> It plays smoothly in chrome and edge on my machine.  It also plays smoothly
> in firefox release.

I responded too quickly to this.

Twitter can serve different content, they have a HD and low-res ones. It's much worse in the low-res one.
(Reporter)

Comment 13

a year ago
Thanks!  Can we make sure to get bug 1347068 uplifted to beta?
(Reporter)

Comment 14

a year ago
I mean bug 1374068 uplifted to beta.
Looks like this was fixed in 55 in bug 1348657.  Ben, can you still reproduce the issue in beta? I can ask QE to verify the fix there if you're busy.
status-firefox55: affected → fixed
status-firefox56: affected → fixed
Flags: needinfo?(bkelly)
(Reporter)

Comment 16

a year ago
Sorry, I think you want bug 1374068 which is only in FF56 so far.
status-firefox55: fixed → affected
Flags: needinfo?(bkelly)
Bug 1374068 which has the actual fix (waiting to be uplifted to 55) is tracked. Tracking "-" on this one.
tracking-firefox55: + → -
(In reply to Ritu Kothari (:ritu) from comment #17)
> Bug 1374068 which has the actual fix (waiting to be uplifted to 55) is
> tracked. Tracking "-" on this one.

As bug 1374068 has been fixed in 55, change the 55 status of this one to "fixed" accordingly. Feel free to reset if I got something wrong.
status-firefox55: affected → fixed
Hi Ben, could you please verify whether this issue is fixed as expected on a latest Nightly build? This will help us decide whether the fix ought to be uplifted to Beta55 or not. Thanks!
Flags: needinfo?(bkelly)
(Reporter)

Comment 20

a year ago
WFM now.
Flags: needinfo?(bkelly)
Assignee: nobody → jyavenard
Depends on: 1374068
Target Milestone: --- → mozilla56
You need to log in before you can comment on or make changes to this bug.