Fix Animation id as uint64_t in WebRenderBridgeParent::RecvDeleteCompositorAnimations()

RESOLVED INVALID

Status

()

Core
Graphics: WebRender
RESOLVED INVALID
11 months ago
11 months ago

People

(Reporter: sotaro, Assigned: sotaro)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

11 months ago
Animation id needs to be uint64_t.
(Assignee)

Updated

11 months ago
Assignee: nobody → sotaro.ikeda.g
(Assignee)

Comment 1

11 months ago
Created attachment 8877412 [details] [diff] [review]
patch - Fix Animation id as uint64_t
(Assignee)

Updated

11 months ago
Attachment #8877412 - Flags: review?(howareyou322)
Comment hidden (typo)

Comment 3

11 months ago
Comment on attachment 8877412 [details] [diff] [review]
patch - Fix Animation id as uint64_t

Review of attachment 8877412 [details] [diff] [review]:
-----------------------------------------------------------------

::: gfx/layers/wr/WebRenderBridgeParent.cpp
@@ +284,5 @@
>    CompositorAnimationStorage* storage =
>      mCompositorBridge->GetAnimationStorage(storageId);
>    MOZ_ASSERT(storage);
>  
> +  for (uint64_t i = 0; i < aIds.Length(); i++) {

The 'i' here is the index of animationIds that wait for clean up. I won't expect we need to use uint64 to count these animationIds.
Attachment #8877412 - Flags: review?(howareyou322) → review-
(Assignee)

Updated

11 months ago
Blocks: 1372409
(Assignee)

Updated

11 months ago
No longer blocks: 1372409
(Assignee)

Comment 4

11 months ago
Yea, it was my misunderstanding. And I already found the true causes of Bug 1372409.
(Assignee)

Updated

11 months ago
Status: NEW → RESOLVED
Last Resolved: 11 months ago
Resolution: --- → INVALID
(Assignee)

Comment 5

11 months ago
I already noticed my fault, but I failed to update my understanding of this bug :(
You need to log in before you can comment on or make changes to this bug.