Status

()

Toolkit
Find Toolbar
RESOLVED WONTFIX
10 months ago
7 months ago

People

(Reporter: L.I.A.R., Unassigned)

Tracking

53 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 months ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:53.0) Gecko/20100101 Firefox/53.0
Build ID: 20170524174214

Steps to reproduce:

1. I use the shortcut '/' to search for some ALL_UPPERCASE_TEXT.
2. I realize that the text is searched for with insensitive case
3. I hit CTRL-f to switch to full-capabilities search
4. I click "Match Case" button


Actual results:

The text I originally entered is switched to smallcase!


Expected results:

The text I entered must stay in the original case with which I entered it!!!

Updated

10 months ago
Component: Untriaged → Find Toolbar
Product: Firefox → Toolkit
I'm having trouble to reproduce the issue as described in comment 0. Can you tell me which addons you have installed? That might help!
Flags: needinfo?(sexxxenator)
(Reporter)

Comment 2

10 months ago
I can reproduce this behaviour with a fresh install... So it is not related to any addon...

FYI, I'm using FF 54.0 (64-bit), but the problem was there long before even 50.

After more extensive testing, this occurs when the text you are looking for exists in the page, not when it does not! And you even don't have to click "Match Case" for the searched text to be lowercased...

e.g. 
1. go to https://help.ubuntu.com/community/ReportingBugs
2. Hit /
3. search for "Transla" (with case)
4. Hit CTRL-f
5. Then the text in the search box is transformed to lowercase

With these more extensive tests, I think I understand the problem:
- when I hit '/' and type some text, FF searches for this text (case insensitively)
- when it finds an occurrence, it selects this match
- when I hit CTRL-f, FF "thinks" I'm doing a fresh new search and considers the already selected text (a match with the wrong case) is the text I want to search.

I don't know what the solution is (since searching for the pre-selected text in the page is also wanted), but I'd like to be able to switch the "Case Sensitive" options when I use the '/' to search for text.

Maybe some boolean should mark the fact that we are in 'quicksearch' mode (set true when entering/false when leaving), thus when hitting CTRL-f, we could prevent executing the code that copies the selected text as the text to search?
Flags: needinfo?(sexxxenator)
(In reply to L.I.A.R. from comment #2)
> - when I hit CTRL-f, FF "thinks" I'm doing a fresh new search and considers
> the already selected text (a match with the wrong case) is the text I want
> to search.

Yeah, I think this is exactly what is happening in this case.

> I don't know what the solution is (since searching for the pre-selected text
> in the page is also wanted), but I'd like to be able to switch the "Case
> Sensitive" options when I use the '/' to search for text.

I understand your request, but that's kinda besides the point of quicksearch.

> Maybe some boolean should mark the fact that we are in 'quicksearch' mode
> (set true when entering/false when leaving), thus when hitting CTRL-f, we
> could prevent executing the code that copies the selected text as the text
> to search?

That might be possible, technically, but we'd have to remember that we opened/ used quicksearch before and how long should we remember that? It's quite tricky to get right and I'm quite sure that it won't be worth the cost. :(
Sounds like this is a WONTFIX.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.