Make tasks that do not have any *new* dependencies depend on the decision task

RESOLVED FIXED in mozilla56

Status

RESOLVED FIXED
2 years ago
10 months ago

People

(Reporter: dustin, Assigned: dustin)

Tracking

unspecified
mozilla56

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Currently, if you have, say, a build task that depends on a docker-image task, it will not be made to depend on the decision task.  The idea is that the docker-images task must depend on the decision task, but that's not the case when that docker-image task was optimized to point to an older, complete task.
Duplicate of this bug: 1372817
Comment hidden (mozreview-request)

Comment 5

2 years ago
mozreview-review
Comment on attachment 8883035 [details]
Bug 1372892: make tasks with optimized dependencies depend on decision task;

https://reviewboard.mozilla.org/r/153992/#review159592
Attachment #8883035 - Flags: review?(bugspam.Callek) → review+

Comment 6

2 years ago
Pushed by dmitchell@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/2f3454d832c6
make tasks with optimized dependencies depend on decision task; r=Callek

Comment 7

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/2f3454d832c6
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla56
backed out for causing  bug 1378744
Status: RESOLVED → REOPENED
Flags: needinfo?(dustin)
Resolution: FIXED → ---
Depends on: 1378744

Comment 9

2 years ago
Backout by cbook@mozilla.com:
https://hg.mozilla.org/mozilla-central/rev/4bd7db49d228
Backed out changeset 2f3454d832c6 for breaking nightly signing - causing bug 1378744
Flags: needinfo?(dustin)
Bug 1378744 being fixed, I think we can re-land this.  But since it hit nightlies, I'll wait until next week instead of doing it over the weekend.
..going to hold off on this a bit longer -- I landed some changes to use JSON-e in .taskcluster.yml which may also affect nightlies, and that hasn't gotten to central yet.  Also, there's the big Windows reveal coming up later this week.

Comment 13

a year ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/bf3ae82e04e6
Status: REOPENED → RESOLVED
Last Resolved: 2 years agoa year ago
Resolution: --- → FIXED

Updated

10 months ago
Product: TaskCluster → Firefox Build System
You need to log in before you can comment on or make changes to this bug.