Netscape webmail fails most functions

VERIFIED WORKSFORME

Status

VERIFIED WORKSFORME
17 years ago
14 years ago

People

(Reporter: thedocbwarren, Assigned: Matti)

Tracking

Trunk
Other
All

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
It would seem as of 0.9.9 and all current nightlies (Windows and Linux x86 and
PPC tested.)  fail to run the commands within Netscape webmail.  Delete and move
to folder do nothing.  This only true as of 0.9.9 and nightlies.  I'm thinking
this is a javascript problem.  This site works with other browsers (Netscape 4.)
(Reporter)

Comment 1

17 years ago
Also, more important and the errors below, you can't send mail.

Here is an error I get when moving to a folder:

Error: GetCookie is not defined
Source File: http://ncmail.netscape.com/html/js/msglist.js
Line: 105

And here are more from a delete:

Error: newImage is not defined
Source File:
http://ncmail.netscape.com/msglist.adp?folder=SW5ib3g=&start=1&cmd=deletemsgs
Line: 477

Error: handleLowColor is not defined
Source File:
http://ncmail.netscape.com/msglist.adp?folder=SW5ib3g=&start=1&cmd=deletemsgs
Line: 469

Comment 2

17 years ago
Reassigning to Browser-General until we can get more information.
These types of errors are usually caused by mistakes in the script,
not by bugs in JS Engine. Compare similar error in this bug:

bug 107170 "siconline.pt - cookie fails, site useless because of bad JS"


The other possibility is this: do you have any Preferences settings
that would block cookies? That would also cause errors like these.

In the meantime, I get a Site Not Found error when I try to go 
to the given URL, http://ncmail.netscape.net. Is there a typo?

Also: since this site require a login, would it be possible
for someone to set up a test account, say with 

                      user= mozilla
                      pwd = bugzilla


Finally, compare bug 133977, "Netscape mail (send) fails on 2002032708"
We might want to dupe one of these bugs against the other one -
Assignee: rogerl → Matti
Component: JavaScript Engine → Browser-General
QA Contact: pschwartau → imajes-qa
(Reporter)

Comment 3

17 years ago
Sorry, ncmail.netscape.com
(Reporter)

Comment 4

17 years ago
Javascript is turn ON.  I accept cookies and the other bug appears to be simular.
(Assignee)

Comment 5

17 years ago
wfm with win2k build 20020412.. (message send, moved, deleted)

Do you block something in edit\preferences\advanced\Scripting... ?
If not: Can you try a new profile with "mozilla -profilemanager" ?


If someone needs a test account : mail me (i have an unused Account)

Comment 6

17 years ago
I have observed this bug as well in moving from mozilla 0.9.7 to 0.9.8 . This
bug is also present in 0.9.9 .

I could not sent e-mail and I could not move or delete files from the main
webmail page.

However when I created a new profile with "mozilla.exe -profilemanager" the
problem was resolved.

Siu Yin
(Reporter)

Comment 7

17 years ago
This problem has been corrected with RC1.  Did try the 0.9.9 on Linux again and
this problem seems to have corrected itself.

Comment 8

17 years ago
Bob: thanks for the update. Based on your findings, marking this
one WORKSFORME. If anyone else can confirm or deny this with an
up-to-date build, please mark this bug "Verified" or reopen it -
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
(Assignee)

Comment 9

17 years ago
v
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.