If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

MinGW Compiler Crashes in Debug Build

RESOLVED WORKSFORME

Status

()

Core
General
RESOLVED WORKSFORME
3 months ago
2 months ago

People

(Reporter: tjr, Unassigned)

Tracking

(Blocks: 1 bug)

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [tor])

Attachments

(1 attachment)

(Reporter)

Description

3 months ago
Created attachment 8877663 [details] [diff] [review]
compiler-error-mingw-debug.patch

Compiling Firefox with --enable-debug crashes the MinGW compiler. The attached patch fixes the crash, but undoubtedly the real fix is fixing MinGW.

Comment 1

3 months ago
I can't reproduce it with GCC 7.1.

Comment 2

2 months ago
That got fixed in GCC 5.2.0 by https://gcc.gnu.org/bugzilla/show_bug.cgi?id=65727. WORKSFORME then.
Status: NEW → RESOLVED
Last Resolved: 2 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.