Machine executing tasks while iCloud signin dialog is displayed after reimage

RESOLVED DUPLICATE of bug 1373118

Status

Firefox Build System
Task Configuration
RESOLVED DUPLICATE of bug 1373118
11 months ago
3 months ago

People

(Reporter: garndt, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 months ago
It was noticed on some machines that it can enter a state of running a task while the initial dialog to sign into Apple iCloud was still displaying.

generic-worker shouldn't start until the puppet configuration is done so I'm not sure where the race is just yet.  Once the machine is fully initialized and rebooted, things seem fine.
(Reporter)

Updated

11 months ago
Summary: iCloud signin dialog after reimage → Machine executing tasks while iCloud signin dialog is displayed after reimage
(Reporter)

Comment 2

11 months ago
This might be fixed by applying the workarounds in this bug to the user that is running the tasks: bug 1059438
See Also: → bug 1059438
(Reporter)

Updated

11 months ago
See Also: → bug 1373118
Depends on: 1373266
(In reply to Greg Arndt [:garndt] from comment #2)
> This might be fixed by applying the workarounds in this bug to the user that
> is running the tasks: bug 1059438

I checked this in a loaner machine and the configs are right, and icloud seems to not be running.
Hi Johan, do you know if this is still a problem? Greg has since left, so I thought you might be a good person to ask - but if you know someone in releng that might have a better idea, feel free to redirect the question. :-)
Flags: needinfo?(jlorenzo)
(I suspect this is a duplicate of bug 1373118)
I'm sorry, I don't know anything about the accounts set up on Mac. Based on a quick poll around the table, nobody from Releng seems to know about them. Relops may, though. Per an `hg annotate`, it seems Dragos set up the machines, back then. Would you be able able to help, Dragos? If not, feel free to redirect.
Flags: needinfo?(jlorenzo) → needinfo?(dcrisan)
I looked on /Users/cltbld/Library/Preferences/com.apple.SetupAssistant.plist and everything looks OK.

:dividehex Do you have any idea if I need to check on other place? I looked first on the puppet code, and this is the file that is changed. The puppet file is modules/disableservices/manifests/user
Flags: needinfo?(dcrisan) → needinfo?(jwatkins)
Status: NEW → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1373118
Flags: needinfo?(jwatkins)

Updated

3 months ago
Product: TaskCluster → Firefox Build System
You need to log in before you can comment on or make changes to this bug.