resize cursor stays after click between columns

VERIFIED WORKSFORME

Status

SeaMonkey
MailNews: Message Display
VERIFIED WORKSFORME
16 years ago
13 years ago

People

(Reporter: Scott Lamb, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9+) Gecko/20020406
BuildID:    2002040616

In the main mail pane, the resize cursor can stick around after a misclick.
Clicking between two columns (where you would drag to resize them) instead of on
a column (as I intended to do, to sort by that column) caused the resize pointer
to stick around and mouse behavior to be weird.

Reproducible: Always
Steps to Reproduce:
1. Go to the main mail pane.
2. Click between two column headers, i.e. the seperator between Subject and Header
3. Move the mouse away

Actual Results:  The mouse cursor stays in the resize (double-ended arrow)
shape. Clicking on messages does nothing. Sometimes other types of clicks
(right-click to get the context menu) return the cursor to its normal shape but
nothing seems to work consistently.

Expected Results:  The mouse cursor should return to the normal pointer shape
and clicking on messages, etc. should work as before.

Bugs 62007, 42927, and 59525 also deal with the resize cursor. I don't think
they're related, but not sure.

Comment 1

16 years ago
I have seen the behaviour you described a week ago when somebody pointed it out
on IRC but I am no longer able to reproduce it.

Could you download a really recent build and see if it wasn't actually fixed in
some other bug.
(Reporter)

Comment 2

16 years ago
It still occurs with the latest RPM I could find (build id 2002041114, the rpm
calls it 2002041111_1.0.0, so from the 1.0 branch).

Comment 3

16 years ago
also seen on Windows (4/15 build)
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All
Hardware: PC → All

Comment 4

16 years ago
behavior also exhibited for the horizontal seperator bar.  build 2002041907 on
linux.  click on the seperator bar, but do not move it.  the cursor turns to
vertical bi-directional arrow, and does not allow clicking anywhere except the
horizontal separator bar.  move the seperator bar (resize the panes) to return
the cursor to normal working condition.

Comment 5

16 years ago
*** Bug 138986 has been marked as a duplicate of this bug. ***

Comment 6

16 years ago
Check the comments in bug 138986 on this.   It practically disables the mailbox
and thread pane in mail/news.

Comment 7

16 years ago
Yes. When I originally experienced this bug, getting stuck in the 'resize' mode
prevented me from doing anything in mailnews.

Comment 8

16 years ago
It also effectively disabled the menus and navigation bar of the browser.

This may be the wrong component.  It does not affect only mail/news.  It affects
the sidebar as well.  Or any other split window operation.   The dupe just filed
puts it in XP Toolkits/Widgets.   I'd suggest putting the mozilla1.0,regression
as keywords; I'll probably be shot for suggesting it, but its annoying enough.



Comment 9

16 years ago
it cannot be a 'regression' since it never happened before

Comment 10

16 years ago
A change has caused a formerly working behavior to not work.  Hence, a regression.

See the part of the definition of the regression keyword: Also, for problems
outside those identified in precheckin and smoke tests that were found in
current builds that were **known know to be working in previous builds.** 

Comment 11

16 years ago
*** Bug 136809 has been marked as a duplicate of this bug. ***

Comment 12

16 years ago
*** Bug 139373 has been marked as a duplicate of this bug. ***

Comment 13

16 years ago
Please note that bug 136809 was filed regarding a cursor problem in the Browser
component, NOT the Mail / News component, so this issue is affecting other
components as well.

Comment 14

16 years ago
Ah ha!  Examining my problem in the browser component of RC1 on 9.2.2, I see
that whenever I use the scroll wheel on my Kensington Mouse-In-A-Box Optical Pro
(driver:  MouseWorks 5.7), the cursor problem shows up.  See bug 123172 for more
information on problems with scrolling with Kensington input devices on the Mac OS.

Comment 15

16 years ago
I've seen what may be a related issue.  When opening an LDAP directory, I did a
query resulting in six listings.  Upon attempting to resize the window by
dragging on the lower-right corner, I could only resize to maybe 600x400, at
which point the window would not get any larger.  The cursor stayed as a
diagonal resize, regardless of whether I was over the Mozilla window or
elsewhere.  I also could not access other windows, I had to kill the Mozilla
process. to recover.  I'm running RC1.0 on Windows 98SE.

Comment 16

16 years ago
*** Bug 141443 has been marked as a duplicate of this bug. ***

Comment 17

16 years ago
I don't see the problem any more with Linux 2002051009 RC2 branch. Has this been
fixed ?
(Reporter)

Comment 18

16 years ago
I'm no longer seeing it either. I'm using the trunk, build ID 2002051011. It
would be nice to know if it's fixed or just temporarily hidden for some reason.

I'm the original reporter; should I mark this as WORKSFORME? Sounds like it's
for this sort of situation.

Comment 19

16 years ago
*** Bug 146138 has been marked as a duplicate of this bug. ***

Comment 20

16 years ago
Reporter: Yes I think this should be resolved as WORKSFORME, since nobody seems
to have seen it for a long time ...
(Reporter)

Comment 21

16 years ago
Done.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Comment 22

16 years ago
marking verified worksforme
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.