High memory usage after successive loads of a page

RESOLVED DUPLICATE of bug 1374037

Status

()

RESOLVED DUPLICATE of bug 1374037
2 years ago
a year ago

People

(Reporter: mkaply, Assigned: esawin)

Tracking

Trunk
ARM
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(5 attachments)

(Reporter)

Description

2 years ago
We have an OEM reporting that if they continually load a page like yahoo.com, att.start.net or amazon.com or go back between them, memory usage starts jumping on Fennec and does not really ever drop down.

In our testing, we're seeing similar behavior.

The easiest way to see this is start Firefox.

Run:

adb shell dumpsys meminfo | grep org.mozilla.firefox

navigate to yahoo.com. and then run 

adb shell dumpsys meminfo | grep org.mozilla.firefox

again.

Keep hitting reload, then checking meminfo. Or navigate to amazon and check meminfo.

You'll see memory usage continue to climb.

In their testing, they did this 70-80 times.
Assignee: nobody → esawin
OS: Unspecified → Android
Hardware: Unspecified → ARM
Version: unspecified → Trunk
Any updates or questions on this issue?  This is blocking a significant OEM distribution.
Flags: needinfo?(esawin)
(Assignee)

Comment 2

2 years ago
100 page reloads on amazon.com - Fennec 54 - Nexus 7
Fresh start: 178633 kB
Page reloads (100): 273754 kB - 343371 kB
Tab closed: 236064 kB

Memory usage jumped between 270 MB  and 340 MB without showing a clear (leaky) growth. Memory usage jumped back to 240 MB after closing the tab.

Similar results were shown on different URL/device/Fennec version combinations. I conclude that memory usage does not show incremental growth on successive reloads of a page.
Flags: needinfo?(esawin)
(Assignee)

Comment 3

2 years ago
str
New STR:
1. Launch Fennec.
2. Open URL (amazon.com).
3. Push Android back button (back to Fennec home screen).
4. Push Android back button (back to Android home screen).
5. Repeat.

New STR on amazon.com - Fennec 54 Nexus 4
Fresh start: 161241 kB
Iterations: 225603 kB - 1117643 kB (and increasing)
Tab closed at 707307 kB: 659957 kB

With the STR given above, memory usage continues to climb in increments of ~5-10 MB and sometimes in jumps of ~50 MB per iteration.
Closing the tab does seem to release memory for the currently loaded tab as before, but does not release the previously leaked memory.
(Assignee)

Comment 4

2 years ago
Created attachment 8880816 [details]
Memory report: amazon.com initial page load
(Assignee)

Comment 5

2 years ago
Created attachment 8880817 [details]
Memory report: amazon.com iteration at 790 MB
(Assignee)

Comment 6

2 years ago
Created attachment 8880820 [details]
Memory report: amazon.com iteration at 1350 MB
(Assignee)

Updated

2 years ago
Flags: needinfo?(mh+mozilla)
(Assignee)

Comment 7

2 years ago
Created attachment 8883306 [details]
/proc/id/maps initial load at 200 MB

Note: summed up mappings for /dev/kgsl-3d0 at ~24 MB.
(Assignee)

Comment 8

2 years ago
Created attachment 8883307 [details]
/proc/id/maps iteration at 1000 MB

Note: summed up mappings for /dev/kgsl-3d0 at ~454 MB.
(Reporter)

Comment 9

2 years ago
Do we have anything to report on this? Thanks.
(Assignee)

Comment 10

2 years ago
I fail to reproduce this on Fennec Nightly and Beta. I'm not sure whether it has been fixed or if something else is playing into this.

In the meanwhile, would it be possible for the OEM to verify this on Firefox Beta (55.0b5)?
(Assignee)

Comment 11

2 years ago
Bug 1374037 might have the explanation why we only see this issue on the 54 release channel.
If the OEM can still reproduce this on 55, then it's an unrelated issue and will need further investigation.
Flags: needinfo?(mh+mozilla)
(Assignee)

Updated

a year ago
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1374037
You need to log in before you can comment on or make changes to this bug.