www.kaltenkirchen.de: Javascript responsible for navigation via navbar does not work

VERIFIED WORKSFORME

Status

Tech Evangelism Graveyard
German
P2
critical
VERIFIED WORKSFORME
16 years ago
3 years ago

People

(Reporter: tessarakt, Assigned: Tristan Nitot)

Tracking

Details

(Whiteboard: [havefix][havecontact], URL)

Attachments

(4 attachments)

(Reporter)

Description

16 years ago
- Go to http://www.kaltenkirchen.de
- click on the image
  you will get to http://www.kaltenkirchen.de/html/main.html
- hover over a menu item, like "Termine"
  -> The item will be highlighted
- click on it
  -> Mozilla says "Transferring data from www.kaltenkirchen.de...", but nothing
     happens

In IE5.5, it works.

Without Javascript, it does not work either (the links point to the menu itself
without Javascript).

This is a website of a town in Northern Germany (my hometown).
Confirming...
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Updated

16 years ago
Summary: Javascript responsible for navigation via navbar does not work → www.kaltenkirchen.de: Javascript responsible for navigation via navbar does not work
(Reporter)

Comment 2

16 years ago
From: Jens Müller <jens@unfaehig.de>
Subject: (Un-)benutzbarkeit mit modernen Browsern
To: feedback@kaltenkirchen.de
Date: Tue, 28 May 2002 00:07:49 +0200
X-Sent: 7 minutes, 10 seconds ago
Message-ID: <.1022537269.fsf@debian.jens.unfaehig.de>
Organization: eNode Internet Services GbR, Kaltenkirchen, DE

Siehe http://bugzilla.mozilla.org/show_bug.cgi?id=137316

Eine Stellungnahme wäre nett.

Ansonsten werde ich das Problem mal für technische Laien aufbereiten
und auf einer der nächsten Stadtvertretungssitzungen deutlich machen.
(Reporter)

Comment 3

16 years ago
Translation:

Subject: (Un-)usability with modern browsers

See http://bugzilla.mozilla.org/show_bug.cgi?id=137316

A statement would be nice.

Otherwise I will prepare the problem for technical laymen and raise the issue on
one of the next sessions of the town council.

(Reporter)

Comment 4

16 years ago
I just got an e-mail from the webdesign company to the town administration as Cc:

Obviously the responsible person in the town administration has informed the
company about the complaint and asked for a statement.

The statement basically says:

It explains what Mozilla says and that ignorable little users use it. A 100%
support for all browsers would increase development time or decrease
functionality and cause higher costs.

It also cites mozilla.org saying: "Mozilla 1.0 Release Candidate 3 has been
released. It contains many fixes
for crashes and other problems found in RC2. Please download RC3 and help
us verify our fixes." and emphases that Mozilla RC3 is not a final release.
(Reporter)

Comment 5

16 years ago
Of course, it is irrelevant that Mozilla is not a final release, because the
inaccessibilty of the page is caused by the page, not by Mozilla.

Opera cannot access the page, either.

Any suggestions what I should write to these two guys?
Created attachment 85255 [details]
what it looks like in ie6 after "Termine" has been clicked

As you can see, nothing special about that "menu". Haven't looked into the
code, but I suppose they just make a div visible through the DOM - no problem
to make that work in Mozilla too, using actual *W3C* DOM calls.

Also noticed a Java applet on the bottom left which didn't appear at all on
Mozilla. They're using the <applet> tag and no <object>; this might be the
problem. No doctype given, so I can't validate this.

Reporter: Could you attach the exact e-mail they sent you back (the German
version)?
(Reporter)

Comment 7

16 years ago
Well, I don't want to do that without the author's consent.
(Reporter)

Comment 8

16 years ago
My eMail to the town administration:

Sehr geehrter Herr Schröder,

dazu möchte ich folgendes anmerken:

- In der entsprechenden Sektion der Fehlerdatenbank von Mozilla werden
  nur Seiten erfaßt, bei denen die fehlerhafte Darstellung mit Mozilla
  an der Seite und nicht an Mozilla liegt. Ein Mitarbeiter des
  Mozilla-Projektes hat den Bug-Report bestätigt und damit zugleich,
  daß hier kein Fehler von Mozilla vorliegt.

  Im übrigen empfehle ich die Lektüre von
  <http://bugzilla.mozilla.org/show_bug.cgi?id=137316>. 

- Auch der Browser Opera hat dieselben Probleme mit der Darstellung
  der Website.

- Die Nicht-Zugänglichkeit der Seite wird durch Javascripts
  verursacht, die nicht den Standards entsprechen, insbesondere nicht
  dem DOM-Standard (Document Object Model) des W3C. Kein moderner
  Browser, auch nicht der Internet Explorer, hat mit standardkonformen
  Websites Probleme.

- kaltenkirchen.de verwendet Javascripts für Funktionalität, die
  problemlos server-side erledigt werden könnte. Dafür spricht auch,
  daß viele Benutzer Javascript aus Sicherheitsgründen in ihrem
  Browser deaktivieren.

- AOL hat vor, in absehbarer Zeit den auf Mozilla basierenden Netscape
  in seiner Software zu verwenden. Es ist nicht davon auszugehen, daß
  dieser bis dahin fehlerhafte Seiten wie http://www.kaltenkirchen.de/
  unterstützen wird.

- Es ist abzusehen, daß zukünftige Gesetzgebung insbesondere für
  Internet-Auftritte von öffentlichen Stellen gesteigerte
  Anforderungen für die Zugänglichkeit für Behinderte einführt. Diese
  Anforderungen lassen sich am einfachsten und kostengünstigsten
  erfüllen, indem die Seiten nach den Standards des W3C entwickelt
  werden.



Außerdem möchte ich bereits jetzt informell anfragen, ob ein Zugang zu
den Verträgen der Stadt mit der Webdesign-Agentur nach dem
schleswig-holsteinischen Informationsfreiheitsgesetz möglich ist und
in welcher Höhe dafür voraussichtlich Gebühren anfallen würden.

Mit freundlichen Grüßen

Jens Müller
(Reporter)

Comment 9

16 years ago
Translation:

Dear Mr. Schröder,

to that I have some remarks:

- In the relevant section of the Mozilla bug tracking DB only those pages get
listed where the wrong rendering is due to the page and not due to Mozilla. A
Mozilla project member has confirmed the bug and thereby also confirmed that
there is no bug of Mozilla in this case.

Please also have a look at <http://bugzilla.mozilla.org/show_bug.cgi?id=137316>.

- Opera has the same problems with the page.

- The Inaccessibility of the page is caused by Javascripts not conforming with
the standards, esp. the W3C DOM standard. No modern browser, esp. not Internet
Explorer, has problems with standard-conformant pages.

- kaltenkirchen.de uses Javascript for functionality that could easily be
provided server-side. This would also be good because many users disable JS for
security reasons.

- AOL has plans for using Mozilla based Netscape in its software in the near
future. I doubt that that version will support broken pages like
http://www.kaltenkirchen.de/.

- New legislation will probably introduce new standards concerning accessibility
for the disabled. This standards will be add more easily if the page is
standards-compliant.



I would also yet like to ask if access to the contract between the town and the
webdesign company would be possible according to the Schleswig-Holstein Freedom
of Information Act, and how high the fees would be approx.

Kind Regards

Jens Müller
mozilla 1.0 final is out...
im working on a fix so that they dont have  "development time increases" or
"functionality decreases" which would "cause higher costs" :)
Severity: major → critical
Priority: -- → P2
its a five line modification :)
they need to modify the MM_findObj in
http://www.kaltenkirchen.de//html/X_RightJava03.js by a one that is working in
mozilla. I will attach a new version of X_RightJava03.js that does that. (any
new dreamweaver version does it... its a dreamweaver generated function :)
Whiteboard: [havefix]
Created attachment 88468 [details]
X_RightJava03.js, fixed.

just linking to this version of the file makes it work everywhere.

Updated

16 years ago
Whiteboard: [havefix] → [havefix][havecontact]
(Reporter)

Comment 13

16 years ago
Just send them (city and webdesigner) another e-mail informing them about the patch.
(Reporter)

Comment 14

16 years ago
Just sent them (city and webdesigner) another e-mail informing them about the patch.
(Reporter)

Comment 15

16 years ago
Wow ...

The site is usable!

It seems as if they have applied the patch.

Can someone please confirm?
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
(Reporter)

Comment 16

16 years ago
Args ...

But look at the attachment!

The content of the navbar is partly not visible.

Can someone try IE and test if it works there?
(Reporter)

Comment 17

16 years ago
Created attachment 94513 [details]
Mozilla displaying the site here

The navbar is too small to display all its contents.
reopening, looks like there are still some issues. trying to figure whats
happenning.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 19

16 years ago
comment #17:

Looks good here. Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1b) Gecko/20020722
(Reporter)

Comment 20

16 years ago
You have opened the same navigation item? Can you send screenshot?

Comment 21

16 years ago
Created attachment 95256 [details]
display in mozilla without any obvious problems

Here it is. I've got exactly the same display on three systems and three
different OSes. 
This may be a font size issue, but I've played with the font settings in
Preferences/Appearance/Fonts and never saw your problem.

By using text zoom, I've been able to reproduce your problem, but at 150% or
above, almost any web page has some issues.

Comment 22

16 years ago
Referring to my previous comment, I think this should be marked as WFM.
I dont have any problem either
(Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021111)

this looks like a font-size issue. try bugging them with that, and reopen this
bug if they mess with everything :)

marking as wfm.
R WFM
Status: REOPENED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → WORKSFORME

Comment 25

15 years ago
v
Status: RESOLVED → VERIFIED

Comment 26

15 years ago
tech evang june 2003 reorg
Component: Europe: West → German
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.