Activity Stream is using a lot of CPU

RESOLVED DUPLICATE of bug 1399965

Status

()

Firefox
Activity Streams: Newtab
P2
normal
RESOLVED DUPLICATE of bug 1399965
8 months ago
5 months ago

People

(Reporter: automatedtester, Unassigned)

Tracking

unspecified
Points:
---

Firefox Tracking Flags

(firefox57 affected)

Details

(Reporter)

Description

8 months ago
In Nightly from 14/06/2017 Nightly CPU usage when activity stream has been quite high. Activity stream appears to be spinning constantly even when there are no new tabs and is doing so in the main Thread.

Performance Profile in https://perf-html.io/public/a9aebd364eb21034302909213c83af28e065cce1/calltree/?thread=0

I am not sure if this a duplicate of bug 1341437 but disabling activity stream has calmed down my CPU a lot!

Comment 1

8 months ago
I have the similar situation when I visit website, the CPU usage is quite high and the cooling fan is buzzing all the time. In fact, it all starts to happen when I visit http://www.dealstaxi.com. I'm not sure about the problem, because it is not using flash at all.

Updated

7 months ago
Component: Activity Streams: General → Activity Streams: Newtab
:automatedtester, we have done a bunch of perf improvements since this bug was reported.  Could you give this another shot and see if the issue still exists?
Flags: needinfo?(dburns)

Updated

5 months ago
status-firefox57: --- → affected
Priority: -- → P2
(Reporter)

Comment 3

5 months ago
It doesnt appear to be happening anymore.
Status: NEW → RESOLVED
Last Resolved: 5 months ago
Flags: needinfo?(dburns)
Resolution: --- → WORKSFORME

Comment 4

5 months ago
My guess is bug 1399965.
Resolution: WORKSFORME → DUPLICATE
Duplicate of bug: 1399965
You need to log in before you can comment on or make changes to this bug.