Responsive Design Mode doesn't show devices after update to 55 Beta 1

RESOLVED DUPLICATE of bug 1373223

Status

RESOLVED DUPLICATE of bug 1373223
a year ago
3 months ago

People

(Reporter: bart-jan, Unassigned)

Tracking

55 Branch

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

a year ago
Created attachment 8878026 [details]
responsive-design-mode.jpg

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:55.0) Gecko/20100101 Firefox/55.0
Build ID: 20170612224034

Steps to reproduce:

Firefox Developer just updated to 55.0 Beta 1.
Then I opened the Responsive Design Mode.


Actual results:

Responsive Design Mode opened and it looks like older (normal) Firefox versions. Meaning that I can't choose between different devices and the responsive design mode is not centered on the page, but is on the left-hand side of the browser.




Expected results:

I expected the responsive design to be in the center of the page and I expected to be able to select a device like iPhone SE or Nexus 5 as described on the page about the responsive design mode:
https://developer.mozilla.org/en-US/docs/Tools/Responsive_Design_Mode
Component: Untriaged → Developer Tools: Responsive Design Mode
Hmm, interesting.  The new RDM you are looking for is only available when multi-process Firefox (e10s) is enabled.  Starting in 55, a notification bar was intended to appear when old RDM opens (bug 1345515) to clarify this, but I am getting the impression that it did not.

Did anything like a notification bar appear when you opened RDM in 55 to explain this?

As for the issue you are reporting, can you check what about:support says in the "Multiprocess Windows" field?
Flags: needinfo?(bart-jan)
(Reporter)

Comment 2

a year ago
I don't know about the multi-process Firefox. 
It worked before, after the update it didn't.

I didn't see a notification bar.

in about:support it says: "0/1 (Disabled by add-ons)" 
So I removed the few addons I had, but that didn't help.

Then I clicked the 'Refresh Firefox' button after that it dit work.
Reinstalled the plugins and everything worked...
Flags: needinfo?(bart-jan)
Thanks for filing!  It sounds like this issue is the same as bug 1373223, so I'll mark this as a duplicate.

Please reopen if it ends up being a separate issue.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1373223

Updated

3 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.