Closed Bug 137325 Opened 18 years ago Closed 16 years ago

Element Properties window doesn't close with control/command+w

Categories

(Core :: User events and focus handling, defect, minor)

defect
Not set
minor

Tracking

()

RESOLVED DUPLICATE of bug 199424

People

(Reporter: joshgold, Assigned: aaronlev)

References

Details

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:0.9.9) Gecko/20020311
BuildID:    2002031103

The properties window (the popup that comes up when I click Properties in the
right-mouse menu with the mouse over a hyperlink) is the only window I've found
on Mozilla that won't close with the control-W key combination.  Every other
window gives you at least that hotkey (if not a file menu with a Close option.)
 It is inconsistent and inconvenient for this window to depend on window-manager
features.

Reproducible: Always
Steps to Reproduce:
1.open a page with hyperlinks
2.move mouse to link
3.hold right mouse-button
4.select "Properties"
5.press C-w futilely

Actual Results:  nothing

Expected Results:  close the properties window
A lot of windows and dialogs don't close with Ctrl+W: Properties, Open Web
Location..., File Bookmark.  Could Ctrl+W be made a default shortcut for all
windows?
Assignee: sgehani → aaronl
Status: UNCONFIRMED → NEW
Component: XP Apps → Keyboard Navigation
Ever confirmed: true
OS: SunOS → All
QA Contact: paw → sairuh
Hardware: Sun → All
Summary: Properties window doesn't close with C-w → Properties window doesn't close with Ctrl-W
none of theom should have. someone force fed it down one window over 
objections.  

we should be consistent,
That would also work.  Page Info accepts Ctrl+W, but I don't know if any other
windows do.
it's the only one i know of, i still object to it.
I don't have a strong opinion either way.
View Source also does not close with ctrl-w in build 2002062508
Summary: Properties window doesn't close with Ctrl-W → Element Properties window doesn't close with control/command+w
*** Bug 164888 has been marked as a duplicate of this bug. ***
Is this very difficult to implement? Not being able to close a window using the
keyboard is a serious accessibility bug, IMHO.

I have to admit I don't understand comment #2 at all.
IMO windows like element properties shouldn't have the ctl/cmd+w shortcut to 
close, particularly if the patch in bug 138633 goes in. 

Windows with a File -> Close menu item should have this shortcut (page info 
shouldn't IMO).
As long as all windows provide some means of closing themselves, everything is
fine. Remeber that no window manager is required to give the user a close button
to click on. They're not even required to provide the user with a mouse cursor.

It's either a keystroke or a button to close the window, or I have to run xkill
and nuke it from orbit. (thankfully this does not take out all of mozilla, only
the window in question) It's not like accel-w is used to do anything else in any
other part of mozilla or anything. Even escape is pretty much not overloaded,
and would work quite well dispite the fact that you can't really cancel an
element properties window.

Anyway, just my two cents on the matter.
The Properties window does close if I press Esc. I still believe that there
should be at least *one* consistent keybinding for closing any window that has a
close window widget - not Esc for some windows/dialogs and Accel+W for others.
Alt+F4 *is* consistent in Windows, but it is so awkwardly placed that I actually
have to lift my elbow to press it.

My vote goes for Accel+W for all dialogs and windows that have a close window
widget. See Bug 199424.

Here's what Accel+W does with 1.6:

Tabless windows          closes
Tabbed windows           tab is closed
View Source              closes
Page Info                closes
Bookmark Manager         closes 
History                  closes 
Download Manager         doesn't
Form Manager             doesn't
Cookie Manager           doesn't
Image Manager            doesn't
Popup Permissions Window doesn't
Password Manager         doesn't
Javascript Debugger      doesn't (internal error)
Switch Profiles Window   doesn't
File Bookmark            doesn't
Preferences window       doesn't
SSL: Edit Ciphers        doesn't
Certificate Manager      doesn't
Security Device Manager  doesn't
Manage CRLs              doesn't (see bug 129097)
Add Languages            doesn't
New Type (Helper apps)   doesn't
Autocomplete Preferences doesn't
Preview Chatzilla Style  doesn't

Now that may have some obscure logic, but many users would just consider it to
be inconsistent and annoying.

Prog.
personally i'm annoyed at accel-w, because i've been using normal windows apps
recently (outlook) and it doesn't do what i foolishly expect. I blame mozilla.
My reply to comment #12 is here:
http://bugzilla.mozilla.org/show_bug.cgi?id=199424#c8

It seems to be the more appropriate bug.

Prog.
Hitting the "Esc" key will close the window.
*** Bug 241020 has been marked as a duplicate of this bug. ***

*** This bug has been marked as a duplicate of 199424 ***
Status: NEW → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
Component: Keyboard: Navigation → User events and focus handling
You need to log in before you can comment on or make changes to this bug.