Fennec 55 startup crash in l10n builds

RESOLVED DUPLICATE of bug 1372911

Status

()

Firefox for Android
General
--
blocker
RESOLVED DUPLICATE of bug 1372911
a year ago
a year ago

People

(Reporter: will69, Unassigned)

Tracking

({regression})

55 Branch
ARM
Android
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

a year ago
Firefox 55.0b1 (ARM) crashes immediately after startup on four different Android devices. There is some white screen flicker and that's it. The process is still running after that and has to be killed via application management. This is a regression from Firefox 54.0b14.

Firefox 54.0b14 is OK.
Firefox 54.0    is OK.
Firefox 55.0b1  is BAD.
Firefox 56.0a1  is OK.

Tested on these devices:

Android 4.4.3  Amazon  KFSOWI
Android 4.4.4  Amazon  SD4930UR
Android 5.1.1  Amazon  KFASWI
Android 6.0.1  Samsung SM-N930F

What makes this somewhat frustrating for end users is that there is no possibility to roll back to the previous version. Installation of the previous version is being denied by the installer. Maybe you should rethink that policy for beta and nightly channels. (Removal of the app would loose all settings.)
(Reporter)

Updated

a year ago
Keywords: regression
Component: Graphics, Panning and Zooming → General
Are you able to get the logcat from the device? There will likely be some useful information there. I assume the crash reporter dialog doesn't appear for you, since you said the process keeps running?
Flags: needinfo?(will69)
I assume you are sideloading the app and that you weren't updating from the Play Store?
(Reporter)

Comment 3

a year ago
(In reply to Marcia Knous [:marcia - use ni] from comment #2)
> I assume you are sideloading the app and that you weren't updating from the
> Play Store?

Yes, since Mozilla does not publish Fennec to the Amazon App Store, I sideloaded it. I needed to sideload on the Samsung device too, because the playstore still had the older version, even though the publication date was a match. Did you pull the new version by any chance?
Flags: needinfo?(will69)
(In reply to will69 from comment #3)
> (In reply to Marcia Knous [:marcia - use ni] from comment #2)
> > I assume you are sideloading the app and that you weren't updating from the
> > Play Store?
> 
> Yes, since Mozilla does not publish Fennec to the Amazon App Store, I
> sideloaded it. I needed to sideload on the Samsung device too, because the
> playstore still had the older version, even though the publication date was
> a match. Did you pull the new version by any chance?

I haven't been able to get an update for Beta from the Play store yet on any of my devices. When I try to sideload on Nexus 6 running 7.0, I get an error "This app isn't compatible with your phone."
(Reporter)

Comment 5

a year ago
(In reply to Kartikaya Gupta (email:kats@mozilla.com) from comment #1)
> Are you able to get the logcat from the device? There will likely be some
> useful information there. I assume the crash reporter dialog doesn't appear
> for you, since you said the process keeps running?

No, I did not see the crash reporter. logcat contains a lot of stuff and I won't post it in full here, because it might contain sensitive information. Let me know what I should grep for. The following is recurring on the Android 4.4.4 device and might be of interest:

W/dalvikvm(32704): threadid=1: thread exiting with uncaught exception (group=0x4160cd88)
E/GeckoCrashHandler(32704): >>> REPORTING UNCAUGHT EXCEPTION FROM THREAD 1 ("main")
E/GeckoCrashHandler(32704): java.lang.IllegalArgumentException: AppCompat does not support the current theme features: { windowActionBar: false, windowActionBarOverlay: false, android:windowIsFloating: false, windowActionModeOverlay: false, windowNoTitle: false }
E/GeckoCrashHandler(32704): 	at android.support.v7.app.AppCompatDelegateImplV7.createSubDecor(Unknown Source)
E/GeckoCrashHandler(32704): 	at android.support.v7.app.AppCompatDelegateImplV7.ensureSubDecor(Unknown Source)
E/GeckoCrashHandler(32704): 	at android.support.v7.app.AppCompatDelegateImplV7.setContentView(Unknown Source)
E/GeckoCrashHandler(32704): 	at android.support.v7.app.AppCompatActivity.setContentView(Unknown Source)
E/GeckoCrashHandler(32704): 	at org.mozilla.gecko.CrashReporter.onCreate(CrashReporter.java:128)
E/GeckoCrashHandler(32704): 	at android.app.Activity.performCreate(Activity.java:5277)
E/GeckoCrashHandler(32704): 	at android.app.Instrumentation.callActivityOnCreate(Instrumentation.java:1087)
E/GeckoCrashHandler(32704): 	at android.app.ActivityThread.performLaunchActivity(ActivityThread.java:2213)
E/GeckoCrashHandler(32704): 	at android.app.ActivityThread.handleLaunchActivity(ActivityThread.java:2325)
E/GeckoCrashHandler(32704): 	at android.app.ActivityThread.access$800(ActivityThread.java:145)
E/GeckoCrashHandler(32704): 	at android.app.ActivityThread$H.handleMessage(ActivityThread.java:1216)
E/GeckoCrashHandler(32704): 	at android.os.Handler.dispatchMessage(Handler.java:102)
E/GeckoCrashHandler(32704): 	at android.os.Looper.loop(Looper.java:145)
E/GeckoCrashHandler(32704): 	at android.app.ActivityThread.main(ActivityThread.java:5266)
E/GeckoCrashHandler(32704): 	at java.lang.reflect.Method.invokeNative(Native Method)
E/GeckoCrashHandler(32704): 	at java.lang.reflect.Method.invoke(Method.java:515)
E/GeckoCrashHandler(32704): 	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:826)
E/GeckoCrashHandler(32704): 	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:642)
E/GeckoCrashHandler(32704): 	at dalvik.system.NativeStart.main(Native Method)
W/dalvikvm(32704): No implementation found for native Lorg/mozilla/gecko/GeckoAppShell;.reportJavaCrash:(Ljava/lang/Throwable;Ljava/lang/String;)V
(Reporter)

Comment 6

a year ago
BTW, fennec-55.0b1.multi.android-i386.apk (x86!) works on at least one device, so this might by ARM only:

Android 5.0.2  Medion P8912
(In reply to will69 from comment #5)
> logcat contains a lot of stuff and I
> won't post it in full here, because it might contain sensitive information.
> Let me know what I should grep for. The following is recurring on the
> Android 4.4.4 device and might be of interest:

Yeah that stack looks relevant. I'll let somebody who works on Fennec take a look.
(Reporter)

Comment 8

a year ago
Here's another crash. Fennec 55.0b1 hangs with an all-white screen:

Android 7.1.2  Google Nexus 5  (LineageOS 14.1-20170606)

excerpt from logcat:

    06-16 10:35:19.780   791   837 W WindowManager: java.lang.IllegalArgumentException: Requested window android.view.ViewRootImpl$W@5c7c7ef does not exist

    06-16 10:35:20.105 18868 18868 E GeckoCrashHandler: java.lang.IllegalArgumentException: AppCompat does not support the current theme features: { windowActionBar: false, windowActionBarOverlay: false, android:windowIsFloating: false, windowActionModeOverlay: false, windowNoTitle: false }

    06-16 10:35:20.105 18868 18868 E art     : No implementation found for void org.mozilla.gecko.GeckoAppShell.reportJavaCrash(java.lang.Throwable, java.lang.String) (tried Java_org_mozilla_gecko_GeckoAppShell_reportJavaCrash and Java_org_mozilla_gecko_GeckoAppShell_reportJavaCrash__Ljava_lang_Throwable_2Ljava_lang_String_2)
(Reporter)

Updated

a year ago
Summary: Fennec 55 startup crash → Fennec 55 startup crash in l10n builds
(Reporter)

Updated

a year ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1372911
You need to log in before you can comment on or make changes to this bug.