Error converting mail to task: guess is not defined

RESOLVED FIXED in 5.4.2.1

Status

RESOLVED FIXED
a year ago
a year ago

People

(Reporter: slemos.satue, Assigned: martinschroeder)

Tracking

({regression})

Lightning 5.4
5.4.2.1
regression

Details

Attachments

(2 attachments)

(Reporter)

Description

a year ago
Created attachment 8878094 [details]
thunderbird_lightning_task_error.PNG

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:53.0) Gecko/20100101 Firefox/53.0
Build ID: 20170518000419

Steps to reproduce:

Select a mail -> right click -> select "Convert to" -> select "Task"


Actual results:

Nothing on UI. In Error Console I found this errors:
ReferenceError: guess is not defined[Saber más]  calExtract.jsm:1284:13
	Extractor.prototype.guess resource://calendar/modules/calExtract.jsm:1284:13
	Extractor.prototype.extractDayMonthNameYear resource://calendar/modules/calExtract.jsm:408:33
	Extractor.prototype.extract resource://calendar/modules/calExtract.jsm:345:9
	calendarExtract.extractFromEmail chrome://calendar/content/calendar-extract.js:121:25
	oncommand chrome://messenger/content/messenger.xul:1:1


Expected results:

A new task should be created with the mail.

Updated

a year ago
Component: Untriaged → Tasks
Product: Thunderbird → Calendar
Version: 52 Branch → Lightning 5.4
Thanks for reporting. Seems to be caused by this change: <https://hg.mozilla.org/comm-central/diff/fd02e757b142/calendar/base/modules/calExtract.jsm> in Bug 1280898. The variable guess was renamed to dateGuess but not all locations were updated.
Blocks: 1280898
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
(Assignee)

Comment 2

a year ago
Created attachment 8878313 [details] [diff] [review]
Patch v1
Assignee: nobody → mschroeder
Status: NEW → ASSIGNED
Attachment #8878313 - Flags: review?(philipp)
(Assignee)

Updated

a year ago
Attachment #8878313 - Flags: approval-calendar-esr?(philipp)
Attachment #8878313 - Flags: approval-calendar-beta?(philipp)
Attachment #8878313 - Flags: review?(philipp)
Attachment #8878313 - Flags: review+
Attachment #8878313 - Flags: approval-calendar-esr?(philipp)
Attachment #8878313 - Flags: approval-calendar-esr+
Attachment #8878313 - Flags: approval-calendar-beta?(philipp)
Attachment #8878313 - Flags: approval-calendar-beta+
(Assignee)

Updated

a year ago
Keywords: checkin-needed

Comment 3

a year ago
https://hg.mozilla.org/comm-central/rev/0cac30b866ef093d76eadbe6d55f5d1c916f39d2
Status: ASSIGNED → RESOLVED
Last Resolved: a year ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → 5.8

Comment 4

a year ago
Beta (TB 55, Calendar 5.7):
https://hg.mozilla.org/releases/comm-beta/rev/0019f0036204dda4cf920002a17829a55baa6aa0
Target Milestone: 5.8 → 5.7

Comment 5

a year ago
ESR (TB 52, Calendar 5.4)
https://hg.mozilla.org/releases/comm-esr52/rev/6ea4b3bc5ba14a8bc911b227779a05888ea63c13
Target Milestone: 5.7 → 5.4.2
(Assignee)

Comment 6

a year ago
5.4.2 has already been released, so this should be in 5.4.3 then.
Target Milestone: 5.4.2 → 5.4.3
(Assignee)

Comment 7

a year ago
Now I see, we need a new version 5.4.2.1 according to the tagging on comm-esr52. ;-)
Target Milestone: 5.4.3 → 5.4.2.1
You need to log in before you can comment on or make changes to this bug.