Firefox does not hide toolbars in Full Screen mode

RESOLVED DUPLICATE of bug 740148

Status

()

RESOLVED DUPLICATE of bug 740148
a year ago
a year ago

People

(Reporter: mshkrebtan, Unassigned)

Tracking

54 Branch
x86_64
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:53.0) Gecko/20100101 Firefox/53.0
Build ID: 20170608105825

Steps to reproduce:

OS: macOS Sierra 10.12.5.
Firefox version: 54.0.
Firefox profile: new.
Add-ons disabled: yes.

1. Enter Full Screen mode
2. Right-click on a toolbar and check 'Hide Toolbars' or set browser.fullscreen.autohide to true.


Actual results:

Toolbars do not hide.


Expected results:

Toolbars should hide.
(Reporter)

Updated

a year ago
Component: Untriaged → Toolbars and Customization
OS: Unspecified → Mac OS X
Hardware: Unspecified → x86_64

Comment 1

a year ago
Did it use to work with FF53/52 or older?
Flags: needinfo?(mshkrebtan)
(Reporter)

Comment 2

a year ago
(In reply to Loic from comment #1)
> Did it use to work with FF53/52 or older?

No, it did not work with older versions either.
Flags: needinfo?(mshkrebtan)

Comment 3

a year ago
This is platform behaviour on OS X. Other apps behave the same way. The same thing does *not* happen when you use DOM full screen (e.g. you full screen a video using the associated button, or a webpage uses the DOM requestFullscreen() method.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 740148
You need to log in before you can comment on or make changes to this bug.