LLVM chosen for stylo build by mach is broken on macOS

RESOLVED DUPLICATE of bug 1368163

Status

P1
normal
RESOLVED DUPLICATE of bug 1368163
a year ago
8 months ago

People

(Reporter: jdm, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Stylo])

(Reporter)

Description

a year ago
On a new Sierra MBP, I set up a new mozilla-central environment and said that I wanted to work on stylo. The LLVM that was downloaded for me is broken and consumes 100% cpu forever in the stylo build when invoked by bindgen. Others have reported the same issue; I worked around it by installing LLVM 4.0 from homebrew and using that instead.
(Reporter)

Updated

a year ago
Blocks: 1302028, 1243581
Flags: needinfo?(nfroyd)
Priority: -- → P1
Whiteboard: [Stylo]
Dollars to donuts this is a dup of bug 1368163.
Status: NEW → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(nfroyd)
Resolution: --- → DUPLICATE
Duplicate of bug: 1368163

Updated

8 months ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.