Closed Bug 1373335 Opened 4 years ago Closed 4 years ago

Top border of Find Toolbar & Web Console blinking/flashing/flickering on black on scrolling

Categories

(Core :: Graphics: Layers, defect)

56 Branch
x86_64
Windows 7
defect
Not set
major

Tracking

()

VERIFIED FIXED
mozilla56
Tracking Status
firefox-esr45 --- unaffected
firefox-esr52 --- unaffected
firefox54 --- unaffected
firefox55 --- unaffected
firefox56 + verified

People

(Reporter: Virtual, Assigned: mattwoodrow)

References

Details

(Keywords: nightly-community, regression)

Attachments

(1 file)

STR:
1. Open some long website page to get scrollbar
2. Scroll with it or use mouse scroll button
3. See that top border of Find Toolbar blinking/flashing/flickering on black on scrolling
I can also see the border blinking when scroll web content if Web Console(Ctrl+Shift+K) is opened
Component: Find Toolbar → Graphics: Layers
Product: Toolkit → Core
No longer blocks: 1359709
Has Regression Range: --- → yes
Thank you very much Alice0775 White for finding specific regression range!
For Web Console, the issue is most visible when it's in "Light" or "Firebug" theme.
Summary: Top border of Find Toolbar blinking/flashing/flickering on black on scrolling → Top border of Find Toolbar & Web Console blinking/flashing/flickering on black on scrolling
[Tracking Requested - why for this release]: Regression
The video on https://www.wired.com/story/flight-rail-vectorr-atmospheric-railway-train overlaps the chrome as a black box during scrolling. I'm going to assume that that's also this bug.
Assignee: nobody → matt.woodrow
Flags: needinfo?(matt.woodrow)
(In reply to Matt Woodrow (:mattwoodrow) from comment #8)
> Try push:
> https://treeherder.mozilla.org/#/
> jobs?repo=try&revision=bd8be33db1e07d8fcc2ebcb25b027bcc802fa6f0

FYI,
The try build fixes Bug 1373830 and Bug 1373528.
However, The try build does not fix Bug 1373479.
Duplicate of this bug: 1374613
Comment on attachment 8879741 [details]
Bug 1373335 - Make sure we clip the opaque region in render target coordinate space, since complex transforms mean that we can't always have a rectangular representation of clips in layer space.

https://reviewboard.mozilla.org/r/151084/#review156432

This is all so complicated... your patch looks plausible but I might have missed bugs.

::: gfx/layers/composite/LayerManagerComposite.cpp:386
(Diff revision 1)
>    for (Layer* child = aLayer->GetLastChild(); child; child = child->GetPrevSibling()) {
> -    PostProcessLayers(child, localOpaque, descendantsVisibleRegion, ancestorClipForChildren);
> +    MOZ_ASSERT(aLayer->AsContainerLayer()->UseIntermediateSurface());
> +    LayerComposite* childComposite = static_cast<LayerComposite*>(child->AsHostLayer());
> +    PostProcessLayers(child, localOpaque, descendantsVisibleRegion,
> +                      ViewAs<RenderTargetPixel>(childComposite->GetShadowClipRect(),
> +                                                PixelCastJustification::RenderTargetIsParentLayerForRoot),

not sure this PixelCastJustification completely matches what you're doing
Attachment #8879741 - Flags: review?(mstange) → review+
(In reply to Markus Stange [:mstange] from comment #11)
 
> not sure this PixelCastJustification completely matches what you're doing

It doesn't really, the true reason is RenderTargetIsParentLayerIfParentLayerHasIntermediateSurface, but that doesn't exist, so I went for the closest :)
Pushed by mwoodrow@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/e9c2da54cfed
Make sure we clip the opaque region in render target coordinate space, since complex transforms mean that we can't always have a rectangular representation of clips in layer space. r=mstange
(In reply to Matt Woodrow (:mattwoodrow) from comment #12)
> (In reply to Markus Stange [:mstange] from comment #11)
>  
> > not sure this PixelCastJustification completely matches what you're doing
> 
> It doesn't really, the true reason is
> RenderTargetIsParentLayerIfParentLayerHasIntermediateSurface

Seems like it's worth adding :)
https://hg.mozilla.org/mozilla-central/rev/e9c2da54cfed
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla56
I'm marking this bug as VERIFIED, as issue was fixed, starting with Mozilla Firefox Nightly 56.0a1 (2017-06-23). Thanks.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.