If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Checkboxes and radio buttons are not displayed on Firefox 54+ when <meta http-equiv="MSTHEMECOMPATIBLE" content="no"> is specified

VERIFIED FIXED in Firefox 55

Status

()

Core
CSS Parsing and Computation
VERIFIED FIXED
3 months ago
2 months ago

People

(Reporter: kohei, Assigned: mats)

Tracking

({regression, site-compat, testcase})

Trunk
mozilla56
regression, site-compat, testcase
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox54- wontfix, firefox55+ verified, firefox56 verified)

Details

(Whiteboard: [fixed by bug 966240])

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

3 months ago
Created attachment 8878220 [details]
testcase

Reported in https://support.mozilla.org/en-US/questions/1164314

https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=a7000da4b6e2a79c5750dad71095865bdf75be04&tochange=db62e3ac853f7c4d8f045629358264ebf822398c

Culprit: Bug 605985
(Reporter)

Updated

3 months ago
Has Regression Range: --- → yes
Flags: needinfo?(mats)
(Reporter)

Comment 1

3 months ago
[Tracking Requested - why for this release]: A site compatibility regression in Firefox 54 affecting certain sites.
status-firefox54: --- → affected
status-firefox55: --- → affected
status-firefox56: --- → affected
tracking-firefox54: --- → ?
tracking-firefox55: --- → ?
(Assignee)

Comment 2

3 months ago
Interesting, I had no idea we had this feature.
http://searchfox.org/mozilla-central/rev/20d16dadd336e0c6b97e3e19dc4ff907744b5734/dom/base/nsContentSink.cpp#342,349

It looks like Chrome and Safari doesn't support it.  I can't detect any rendering
difference on form controls anyway.  (I haven't checked Edge.)

I tend to think we should simply remove it.
Flags: needinfo?(mats)
(Assignee)

Comment 3

3 months ago
I don't see that it does anything in Edge either.
(Reporter)

Updated

3 months ago
Depends on: 966240

Comment 4

3 months ago
Per comment #2 & #3, track 54- and mark 54 won't fix.
status-firefox54: affected → wontfix
tracking-firefox54: ? → -
(In reply to Mats Palmgren (:mats) from comment #2)
> Interesting, I had no idea we had this feature.
> http://searchfox.org/mozilla-central/rev/
> 20d16dadd336e0c6b97e3e19dc4ff907744b5734/dom/base/nsContentSink.cpp#342,349
> 
> It looks like Chrome and Safari doesn't support it.  I can't detect any
> rendering
> difference on form controls anyway.  (I haven't checked Edge.)
> 
> I tend to think we should simply remove it.

+1

Comment 6

3 months ago
duplicate
<!DOCTYPE html>
<html>
    <head>
        <meta http-equiv="msthemecompatible" content="no">
    </head>
    <body>
        The <input type="checkbox" /> checkbox
    </body>
</html>
tracking for 55 as web compat regression
tracking-firefox55: ? → +
(Reporter)

Comment 8

3 months ago
Created attachment 8878747 [details]
revised testcase
Attachment #8878220 - Attachment is obsolete: true
(Reporter)

Comment 9

3 months ago
As this testcase shows, radio buttons are also invisible with MSThemeCompatible = no.
Summary: Checkboxes are not displayed on Firefox 54+ when <meta http-equiv="MSTHEMECOMPATIBLE" content="no"> is specified → Checkboxes and radio buttons are not displayed on Firefox 54+ when <meta http-equiv="MSTHEMECOMPATIBLE" content="no"> is specified
(Reporter)

Comment 10

3 months ago
Posted the site compatibility note: https://www.fxsitecompat.com/en-CA/docs/2017/checkboxes-and-radio-buttons-are-not-displayed-when-msthemecompatible-is-disabled/
(Assignee)

Comment 11

3 months ago
Fixed by bug 966240.
Assignee: nobody → mats
Status: NEW → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → FIXED
Whiteboard: [fixed by bug 966240]
(Reporter)

Comment 12

3 months ago
Verified with the latest Nightly, 56.0a1 (2017-06-17) (64-bit) using the testcase above.
Status: RESOLVED → VERIFIED
status-firefox55: affected → fixed
status-firefox56: affected → fixed
Given that we dropped MSTHEMECOMPATIBLE in Bug 966240, I can't think we really need to mention this in the docs?
Keywords: dev-doc-needed
(Assignee)

Comment 14

3 months ago
Chris, since this was a rather obscure feature, I think we can simply
remove all mentions of it on MDN (if there are any).
(Reporter)

Updated

3 months ago
status-firefox55: fixed → verified
status-firefox56: fixed → verified
status-firefox-esr52: --- → unaffected
(Reporter)

Updated

3 months ago
Duplicate of this bug: 1375923
(Reporter)

Comment 16

3 months ago
[Tracking Requested - why for this release]: Looks like we've got a duplicate report about http://magicmail.linuxmagic.com/ which is used by various ISPs. We should probably fix the issue with the upcoming 54.0.1 release.
status-firefox54: wontfix → affected
tracking-firefox54: - → ?
We've already go to build for 54 dot release. It's too late. Mark 54 won't fix.
status-firefox54: affected → wontfix
tracking-firefox54: ? → -

Comment 18

3 months ago
Created attachment 8882669 [details]
WSJ email button noop in 54.0.1. Op OK in 53.0.3

WSJ email button noop in 54.0.1. Op OK in 53.0.3
(Reporter)

Updated

3 months ago
Duplicate of this bug: 1377783
(Reporter)

Updated

3 months ago
Duplicate of this bug: 1377922
Target Milestone: --- → mozilla56
You need to log in before you can comment on or make changes to this bug.