Intermittent /html/browsers/windows/targeting-cross-origin-nested-browsing-contexts.html | Unable to locate window: 6442450945

RESOLVED FIXED in Firefox 56

Status

defect
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: intermittent-bug-filer, Assigned: jgraham)

Tracking

(Blocks 1 bug, {intermittent-failure})

Version 3
mozilla57
All
macOS
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox56 fixed, firefox57 fixed)

Details

(Whiteboard: [stockwell unknown])

Attachments

(1 attachment, 1 obsolete attachment)

Duplicate of this bug: 1373454
See Also: → 1374448
Whiteboard: [stockwell needswork]
No, I don't think that this bug is dependent on bug 1373444. If you have a look at any of the logs of failing tests you see a content crash of Firefox which is the reason why the window cannot be found. So it's just a race condition before Firefox get shutdown by the crash reporter. The crash itself is covered as bug 1387684.

Sadly this test failure should be the result of the race and only happens when switchToWindow is called after the content process crashed and before Firefox is shutdown. In most cases such a second failure for a test doesn't make sense to get starred.

My proposal is to wait until bug 1387684 has been fixed.
Depends on: 1387684
No longer depends on: marionette-window-tracking
Whiteboard: [stockwell needswork] → [stockwell unknown]
So the patch on bug 1387684 landed 5 days ago but didn't stop this failure from happening. Interestingly we do not have any more failures since August 25th. Also this is/was a MacOS only issue.
OS: Unspecified → Mac OS X
Hardware: Unspecified → All
So the failure is still happening as OF data shows. I find it very hard by just looking at the minimal log output to figure out where we even fail on the runner side. Why don't we print out any stack from Python code of the runner which will help us to investigate wpt failures?
Flags: needinfo?(james)
The fundamental issue here is that we are throwing for errors during teardown that we simply shouldn't.
Flags: needinfo?(james)
Comment on attachment 8903183 [details]
Bug 1373444 - Look for NoSuchWindowException when waiting for manual browser close in wpt,

https://reviewboard.mozilla.org/r/174956/#review181342

::: commit-message-6007d:4
(Diff revision 1)
> +Bug 1373444 - Look for NoSuchWindowException when waiting for manual browser close in wpt, r=maja_zf
> +
> +This method works by running a long-running script and catching the exception when
> +it is interrupted. But the exception changed so we much make a corresponding change here.

s/much/must/
Attachment #8903183 - Flags: review?(mjzffr) → review+
Pushed by james@hoppipolla.co.uk:
https://hg.mozilla.org/integration/mozilla-inbound/rev/00f0c5109767
Ignore exceptions during wpt test teardown, r=maja_zf
https://hg.mozilla.org/integration/mozilla-inbound/rev/ec49322e332f
Look for NoSuchWindowException when waiting for manual browser close in wpt, r=maja_zf
https://hg.mozilla.org/mozilla-central/rev/00f0c5109767
https://hg.mozilla.org/mozilla-central/rev/ec49322e332f
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla57
Assignee: nobody → james
Comment on attachment 8903182 [details]
Bug 1373444 - Fix typo in wpt harness,

https://reviewboard.mozilla.org/r/174954/#review182000

::: testing/web-platform/tests/tools/wptrunner/wptrunner/executors/executormarionette.py:518
(Diff revision 1)
> -        handle = self.protocol.marionette.window_handles[0]
> +            handle = self.protocol.marionette.window_handles[0]
> -        self.protocol.marionette.switch_to_window(handle)
> +            self.protocol.marionette.switch_to_window(handle)
> -        super(self.__class__, self).teardown()
> +            super(self.__class__, self).teardown()
> +        except Exception as e:
> +            # Ignore errors during teardown
> +            self.logger.warning(traceback.traceback.format_exc(e))

I think you might have an extra `traceback.` here.
Attachment #8903182 - Flags: review+
See previous comment -- I just noticed something broken.
Flags: needinfo?(james)
Attachment #8903183 - Attachment is obsolete: true
You need to log in before you can comment on or make changes to this bug.