Closed Bug 1373594 Opened 3 years ago Closed 2 years ago

HAR logs are not auto exported into the profile directory

Categories

(DevTools :: Netmonitor, defect, P1)

55 Branch
defect

Tracking

(firefox-esr52 unaffected, firefox54 unaffected, firefox55+ verified, firefox56+ verified)

VERIFIED FIXED
Firefox 56
Tracking Status
firefox-esr52 --- unaffected
firefox54 --- unaffected
firefox55 + verified
firefox56 + verified

People

(Reporter: tim, Assigned: rickychien)

References

Details

(Keywords: regression)

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:53.0) Gecko/20100101 Firefox/53.0
Build ID: 20170518000419

Steps to reproduce:

I set the necessary profile keys to activate (automatic) har-Export:

devtools.netmonitor.har.enableAutoExportToFile
devtools.netmonitor.har.forceExport

and opend the inspector (F12) bevor loading the page.



Actual results:

No har folder/file is created within the profile directory. If I go manually to about:blank after the page is loaded, an incomplete har-file (only a few entries) is created. 


Expected results:

On FF 53.0.3 everything works fine: the page is loaded and a har log folder is created within the profile directory. Since 54 (and 55.0b2) it doesn't work anymore.
Component: Untriaged → Developer Tools: Netmonitor
Regression range:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=134a3c1bf3d19bbcaf5b275516b5eb74305cd88b&tochange=4787ae58a7d23e77bb1866e6c7bd7336078c305c

Regressed by bug 1350215.

That said, the issue is not present with FF54, only 55/56. With 54, I'm able to auto-generate HAR files in the /har folder stored in the profile folder.

Ricky, could you check this issue or forwad it to someone else of the devtools team, please.
Blocks: 1350215
Status: UNCONFIRMED → NEW
Has Regression Range: --- → yes
Has STR: --- → yes
Ever confirmed: true
Flags: needinfo?(rchien)
Keywords: regression
Summary: HAR logs were not created since FF 54 → HAR logs are not auto exported into the profile directory
Dear Loic,

thank you very much for the quick response. I totaly agree that the har-file is created on FF 54.0 on very "simple" websites. I tried to create one for reddit.com: even 2 minutes after the page is fully loaded no har file is available in the profile directory.

Regards,
Tim
WFM with heavy pages like Reddit or Amazon, it takes 5-10 sec but the HAR file is created. For Amazon, the size on the disk is 7.40 MB.
It could be an issue only with the 64 bits version. Could you try with the 32 bits version of FF54, please.
http://ftp.mozilla.org/pub/firefox/releases/54.0/win32/en-US/
Hi,

thanks again. I tried both: Windows 10 64bit and Windows 7 32bit with the same results. 

To proof this, a screen capture is available on youtube: https://www.youtube.com/watch?v=THZwyt3G_cA

As you can see there I don't get any har file for the first two websites within this fresh profile directory. Only the last one (google.com) works here. I also tried to wait longer for the har file but without any result -- if you want, I provide 24h version for this ;-).

Regards,
Tim
Assignee: nobody → rchien
Status: NEW → ASSIGNED
Flags: needinfo?(rchien) → qe-verify+
Priority: -- → P1
Tim, thanks for reporting and confirming this issue. I'll take a look.
tracking as a regression in net monitor
Honza,

This regression is caused by bug 1350215 with following mistakes:

* After folder structure changed, some leftovers in har/ haven't been changed to new path accordingly.
* Another mistake is promise refactoring in a series of patches such as this.pageLoadDeferred in resetPageLoadTimeout never been reached.

I've tested and confirmed that HAR logs are able to be exported properly to destination. (Verified on www.google.com, reddit.com, bbc.com, edition.cnn.com)

Here is my setting for testing the automatic HAR log exporting

Enable automatic HAR log exporting in about:config

    devtools.netmonitor.har.enableAutoExportToFile = true
    devtools.netmonitor.har.forceExport = true
    devtools.netmonitor.har.defaultLogDir = ~/Downloads/

* Visit any website

* Open Devtools

* Reload tab to see log file being added in ~/Downloads/
Comment on attachment 8879488 [details]
Bug 1373594 - Fix broken automatic HAR logs exported

https://reviewboard.mozilla.org/r/150792/#review155660

Thanks for fixing this Ricky!

R+

Honza
Attachment #8879488 - Flags: review?(odvarko) → review+
Pushed by rchien@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/0ab5db5483c3
Fix broken automatic HAR logs exported r=Honza
Comment on attachment 8879488 [details]
Bug 1373594 - Fix broken automatic HAR logs exported

Approval Request Comment
[Feature/Bug causing the regression]: bug 1350215.
[User impact if declined]: automatic HAR export doesn't work for developers.
[Is this code covered by automated tests?]: no
[Has the fix been verified in Nightly?]: yes
[Needs manual test from QE? If yes, steps to reproduce]: yes, STR see comment 9.
[List of other uplifts needed for the feature/fix]: no
[Is the change risky?]: no
[Why is the change risky/not risky?]: developer specific feature but it will not impact on user.
[String changes made/needed]: none
Attachment #8879488 - Flags: approval-mozilla-beta?
https://hg.mozilla.org/mozilla-central/rev/0ab5db5483c3
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 56
Comment on attachment 8879488 [details]
Bug 1373594 - Fix broken automatic HAR logs exported

netmonitor regression fix, beta55+
Attachment #8879488 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Ricky, when you requested uplift the fix was not yet in central, so "has the fix been verified in nightly" couldn't have been true yet ;)
I have reproduce this issue by following the STR from comment 9, using an affected Nightly build (2017-06-16).

I can confirm that, the har folder is properly created into the profile directory with 55 beta 4 (20170622173933) and latest Nightly 56.0a1 (2017-06-21). I've tested on google.com, bbc.com, youtube.com and amazon.com on the following platforms: 
- Windows 10 x64
- Mac OS 10.11.6
- Ubuntu 16.04 x64
Status: RESOLVED → VERIFIED
Flags: qe-verify+
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.