[Linux] questionmark icon for DevEdition and Beta when installed replacing the default Firefox that comes with linux

RESOLVED INVALID

Status

()

--
minor
RESOLVED INVALID
2 years ago
a year ago

People

(Reporter: bogdan_maris, Unassigned)

Tracking

Trunk
All
Linux
Points:
---

Firefox Tracking Flags

(firefox54 affected, firefox55 affected, firefox56 affected)

Details

Attachments

(1 attachment)

[Affected versions]:
- Firefox 55.0a2

[Affected platforms]:
- Ubuntu 16.04 32/64bit

[Steps to reproduce]:
1. Uninstalled the default Firefox using the instructions from comment 2 https://askubuntu.com/questions/16758/removing-firefox-in-ubuntu-with-all-add-ons-like-it-never-existed to uninstall firefox
2. Installed DevEdition based on http://kb.mozillazine.org/Installing_Firefox#Linux except I used 'tar xjf instead of zxf'
3. Launch Firefox from terminal with 'firefox' command

[Expected result]:
- Dev Edition starts and has its default Icon.

[Actual result]:
- Dev Edition starts and has questionmark icon (default icon for unknown application on linux I guess).

[Regression range]:
- I don't think this applies now, since I'm not sure this is a Firefox bug to start with. I get the same behavior when I install Fx 50.0 so not a recent regression.

[Additional notes]:
- It's odd that on another machine yesterday the DevEdition Icon was shown when starting DevEdition but today it's showing questionmark icon as well.
- This could most likely not be a Firefox bug, but something that I did wrong when installing/uninstalling Firefox.
- Here is a screenshot of the 
- Note that I did had two userapp-Firefox Developer Edition<...>.desktop files and I deleted the one that did not point to the installed Firefox.
Created attachment 8878489 [details]
Screenshot showing the issue

And here is the screenshot.
Shell integration isn't involved in this bug.
Component: Shell Integration → Installer
Not a Linux expert, but I would guess that whichever .desktop file is being used now just doesn't know where to find the right icon; that installation procedure wouldn't put one anywhere Unity knows to look. You'll have to edit that file to point to the icon in the copy of dev edition that you installed. I think there's one you can use at [install path]/browser/icons/mozicon128.png.

There's also an easier way to install dev edition on Ubuntu, by using Ubuntu Make as described at:
https://www.linuxbabe.com/browser/install-firefox-developer-edition-ubuntu-16-04-linux-mint-18
It sorts all of this out automatically.

I'm closing this bug because it isn't a Firefox bug, but hopefully that helps.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.