Broken cache causes images not to be loaded

VERIFIED DUPLICATE of bug 137805

Status

()

Core
Networking: Cache
VERIFIED DUPLICATE of bug 137805
16 years ago
16 years ago

People

(Reporter: Daniel Bratell, Assigned: gordon)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
CVS build from the trunk today

I'm not sure how to describe this bug, or if I even should file it, but I just
had some trouble loading many webpages I often visit. No images were displayed
and if I tried to load individual images something about "Couldn't show the
image because of a file error" was shown.

I finally narrowed it down to something in my profile's cache. Removing it made
everything work again. If anyone is interested in looking at the problem, I've
saved my broken cache.

I see at least two issues. 

1. The cache was corrupted
2. The corruption wasn't detected

Reproducible: Didn't try

Comment 1

16 years ago
Should be dupe of bug 107322?
(Reporter)

Comment 2

16 years ago
I don't believe that this has anything to do with that bug. I have not deleted
any file inside the cache directory.
Were you running two copies of mozilla/ns6 on the same profile at the same time?
(Reporter)

Comment 4

16 years ago
Is that possible? No, not at the same time, but I've switched back and forth
between two builds when doing performace measurements.

Comment 5

16 years ago
See bug 137474 and bug 137484
http://www.starbids.se rendered with broken images already on first load.

Try "view image" on one of the broken images there, then reload.
I never saw that error message before, "The image ... cannot be displayed,
because it contains errors." That many broken images all of a sudden? This
smells like recent regression.

Comment 6

16 years ago
dup of 137805

*** This bug has been marked as a duplicate of 137805 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
vrfy

this is a strange bug
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.