Linux 32 build perma-orange since 2017-06-14 - gyp.common.GypError: Call to 'pkg-config --cflags gobject-2.0 gthread-2.0 gtk+-2.0' returned exit status 1

RESOLVED FIXED in Thunderbird 56.0

Status

RESOLVED FIXED
a year ago
a year ago

People

(Reporter: jorgk, Assigned: jesup)

Tracking

Trunk
Thunderbird 56.0

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Thunderbird-testfailure: B Linux32])

Attachments

(1 attachment)

(Reporter)

Description

a year ago
Started here:
https://treeherder.mozilla.org/#/jobs?repo=comm-central&revision=6e8cb90569125b04aadbb9f34c2ecc560c07837b

gyp.common.GypError: Call to 'pkg-config --cflags gobject-2.0 gthread-2.0 gtk+-2.0' returned exit status 1 while in /builds/slave/tb-c-cen-lx-000000000000000000/build/mozilla/media/webrtc/trunk/webrtc/media/media.gyp. while loading dependencies of /builds/slave/tb-c-cen-lx-000000000000000000/build/mozilla/media/webrtc/trunk/webrtc/api/api.gyp while loading dependencies of /builds/slave/tb-c-cen-lx-000000000000000000/build/mozilla/media/webrtc/trunk/webrtc/webrtc.gyp while loading dependencies of
(Reporter)

Comment 1

a year ago
gyp.common.GypError: Call to 'pkg-config --cflags gobject-2.0 gthread-2.0 gtk+-2.0' returned exit status 1 while in /builds/slave/tb-c-cen-lx-000000000000000000/build/mozilla/media/webrtc/trunk/webrtc/media/media.gyp. while loading dependencies of /builds/slave/tb-c-cen-lx-000000000000000000/build/mozilla/media/webrtc/trunk/webrtc/api/api.gyp while loading dependencies of /builds/slave/tb-c-cen-lx-000000000000000000/build/mozilla/media/webrtc/trunk/webrtc/webrtc.gyp while loading dependencies of /builds/slave/tb-c-cen-lx-000000000000000000/build/mozilla/media/webrtc/trunk/peerconnection.gyp while trying to load /builds/slave/tb-c-cen-lx-000000000000000000/build/mozilla/media/webrtc/trunk/peerconnection.gyp
gmake[1]: *** [backend.TestManifestBackend] Error 1

M-C last good: 91134c95d68cbcfe984211fa3cbd28d610
M-C first bad: b266a8d8fd595b84a7d6218d7b8c6b7af0

https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=91134c95d68cbcfe984211fa3cbd28d610&tochange=b266a8d8fd595b84a7d6218d7b8c6b7af0

Looks like bug 1341285 - https://hg.mozilla.org/mozilla-central/rev/cbb06ea384e9

Dan, Jesup and Tom: Any hints?
Flags: needinfo?(rjesup)
Flags: needinfo?(mozilla)
Flags: needinfo?(dminor)
(Assignee)

Comment 2

a year ago
Created attachment 8879594 [details] [diff] [review]
disable gyp use_gtk which is only used for code we don't build

Jorg - can you test this patch on comm-central?  Locally it seems to avoid evaluating the pkg-config, but needs to be tested in an environment/repo that fails currently
Attachment #8879594 - Flags: review?(mh+mozilla)
(Assignee)

Updated

a year ago
Assignee: nobody → rjesup
Status: NEW → ASSIGNED
(Reporter)

Comment 3

a year ago
Thanks for the quick response.

(In reply to Randell Jesup [:jesup] from comment #2)
> Jorg - can you test this patch on comm-central?
Yes, I can ;-)
https://treeherder.mozilla.org/#/jobs?repo=try-comm-central&revision=8d2e81fecd0b3e55e166d4d64c068a049ccdf8a5
Flags: needinfo?(rjesup)
Flags: needinfo?(mozilla)
Flags: needinfo?(dminor)
(Reporter)

Comment 4

a year ago
That worked.
Comment on attachment 8879594 [details] [diff] [review]
disable gyp use_gtk which is only used for code we don't build

Review of attachment 8879594 [details] [diff] [review]:
-----------------------------------------------------------------

I think this would be better done in media/webrtc/moz.build... but there are already a lot of webrtc-specific things in build/gyp.mozbuild. File a followup to move them?
Attachment #8879594 - Flags: review?(mh+mozilla) → review+
Duplicate of this bug: 1373485

Comment 7

a year ago
Pushed by rjesup@wgate.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/26bd66776280
disable gyp use_gtk which is only used for code we don't build r=glandium

Comment 8

a year ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/26bd66776280
Status: ASSIGNED → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 56.0
You need to log in before you can comment on or make changes to this bug.