bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Add basic invalidation to PaintedLayerBlobImage

RESOLVED FIXED in Firefox 56

Status

()

Core
Graphics: WebRender
RESOLVED FIXED
a year ago
a year ago

People

(Reporter: jrmuizel, Assigned: jrmuizel)

Tracking

unspecified
mozilla56
Points:
---

Firefox Tracking Flags

(firefox56 fixed)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

a year ago
This makes things noticeably better.
(Assignee)

Comment 1

a year ago
Created attachment 8878718 [details] [diff] [review]
Add simple invalidation to PaintedLayerBlob

This allows us to reuse blob images if they haven't changed. If they have changed we repaint the whole image.
Assignee: nobody → jmuizelaar
Attachment #8878718 - Flags: review?(bugmail)
(Assignee)

Updated

a year ago
Blocks: 1373861
(Assignee)

Updated

a year ago
No longer blocks: 1373861
Depends on: 1373861
Comment on attachment 8878718 [details] [diff] [review]
Add simple invalidation to PaintedLayerBlob

Review of attachment 8878718 [details] [diff] [review]:
-----------------------------------------------------------------

Is this the right patch? Looks unrelated. Also please make sure there's a real commit message and -U8 diff
Comment on attachment 8878718 [details] [diff] [review]
Add simple invalidation to PaintedLayerBlob

Review of attachment 8878718 [details] [diff] [review]:
-----------------------------------------------------------------

Yeah definitely the wrong patch here.
Attachment #8878718 - Flags: review?(bugmail)
(Assignee)

Comment 4

a year ago
Created attachment 8878741 [details] [diff] [review]
The right patch
Attachment #8878718 - Attachment is obsolete: true
Attachment #8878741 - Flags: review?(bugmail)
If this merges to central after bug 1368386 (which seems likely), it'll need to be changed to
AddToValidRegion(regionToPaint);
Attachment #8878741 - Flags: review?(bugmail) → review+
Duplicate of this bug: 1371977

Comment 7

a year ago
Pushed by jmuizelaar@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/efc25dfc9956
Add basic invalidation to PaintedLayerBlobImage. r=kats

Comment 8

a year ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/efc25dfc9956
Status: NEW → RESOLVED
Last Resolved: a year ago
status-firefox56: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla56
You need to log in before you can comment on or make changes to this bug.