Closed Bug 1373969 Opened 3 years ago Closed 3 years ago

The overflow panel shows unnecessary scrollbars and isn't sized appropriately in some situations

Categories

(Firefox :: Toolbars and Customization, defect, P1)

defect

Tracking

()

VERIFIED FIXED
Firefox 56
Iteration:
56.2 - Jul 10
Tracking Status
firefox56 --- verified

People

(Reporter: arai, Assigned: Gijs)

References

Details

(Whiteboard: [photon-structure])

Attachments

(2 files, 1 obsolete file)

Steps to reproduce:
  1. open Nightly 56.0a1 (2017-06-17) (64-bit) on OSX
  2. click hamburger button
  3. click "Customize..."
  4. add 10 items to overflow panel
  5. click "Done"
  6. click overflow panel button (">>")

Actual result:
  overflow panel has scrollbar and only partial content is displayed, even if there's more space on the panel

Expected result:
  items should be displayed as long as there's space
Blocks: 1354086
Summary: The content of overflow panel overflows. → The overflow panel shows unnecessary scrollbars and isn't sized appropriately in some situations
Whiteboard: [photon-structure][triage]
Comment on attachment 8880390 [details]
Bug 1373969 - update overflow chevron state when resetting,

Gah, wrong bug number.
Attachment #8880390 - Attachment is obsolete: true
Attachment #8880390 - Flags: review?(jaws)
Flags: qe-verify?
Priority: -- → P2
Whiteboard: [photon-structure][triage] → [photon-structure]
Flags: qe-verify? → qe-verify+
QA Contact: gwimberly
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
Iteration: --- → 56.2 - Jul 10
Priority: P2 → P1
This is due to the fact that the scrolling container has max-height: 30em, but the panelmultiview tries to size according to content.

The max-height was added in bug 916964.
Blocks: 916964
Comment on attachment 8883028 [details]
Bug 1373969 - do scrolling correctly in overflow panel when it has a panelmultiview,

https://reviewboard.mozilla.org/r/153988/#review159152
Attachment #8883028 - Flags: review?(jaws) → review+
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/d1fcfeef6615
do scrolling correctly in overflow panel when it has a panelmultiview, r=jaws
https://hg.mozilla.org/mozilla-central/rev/d1fcfeef6615
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 56
I have reproduced this bug with nightly 56.0a1 (2017-06-17) on "Linux Mint (64 Bit).

The bug's fix is now verified on Latest Nightly 56.0a1

Build ID 	20170705100248
User Agent 	Mozilla/5.0 (X11; Linux x86_64; rv:56.0) Gecko/20100101 Firefox/56.0

[Bugday-20170705]
I have successfully reproduced this bug with Nightly 56.0a1 (2017-06-17) (32-bit) on windows 10(32bit)

this bug is verified fix with  latest nightly 56.0a1 (2017-07-04) (32-bit)

Build ID: 20170704030203
Mozilla/5.0 (Windows NT 10.0; rv:56.0) Gecko/20100101 Firefox/56.0
QA Whiteboard: [Bugday-20170705]
Verified on Windows, Mac, and Ubuntu.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
Blocks: 1387512
You need to log in before you can comment on or make changes to this bug.