Closed Bug 1374007 Opened 5 years ago Closed 4 years ago

Firefox adds a gray opacity for an html5 video tag poster image

Categories

(Toolkit :: Video/Audio Controls, defect, P1)

54 Branch
defect

Tracking

()

VERIFIED FIXED
mozilla57
Tracking Status
firefox57 --- verified

People

(Reporter: zurd33, Assigned: ralin)

References

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:54.0) Gecko/20100101 Firefox/54.0
Build ID: 20170616092053

Steps to reproduce:

Go to
http://www.tutorialrepublic.com/codelab.php?topic=html5&file=video-element


Actual results:

The poster image on top of the video will be "grayed", there is some kind of opacity on it.


Expected results:

There should not be any opacity. Chrome and Edge works fine (use them to compare the image). This opacity problem doesn't look nice.

Problems happens in Firefox in Linux and Windows.
Component: Untriaged → Audio/Video: Playback
Product: Firefox → Core
This isn't an audio playback issue. It's a design one. It's a matter of guess I guess.

The video isn't playing.
Component: Audio/Video: Playback → Video/Audio Controls
Product: Core → Toolkit
Yes, it's a design issue, not about playback.

Here's an image that shows Chrome, Edge and Firefox, I think it looks much better in Chrome and Edge.
https://s23.postimg.org/pg5pch2u3/firefox-chrome-edge-html5-video-image-poster.jpg

Haven't found a way to remove this opacity, looks like it's built-in into Firefox.
ralin, can you investigate this? I have seen in on occasion too but I don't have reliable STR.
Flags: needinfo?(ralin)
Priority: -- → P1
Status: UNCONFIRMED → NEW
Ever confirmed: true
The grey overlay is by design for the visual refresh[1], but I think it's fine to make it transparent and behave like Chrome and Edge.


[1] http://searchfox.org/mozilla-central/rev/2c9a5993ac40ec1db8450e3e0a85702fa291b9e2/toolkit/themes/shared/media/videocontrols.css#84-86
Flags: needinfo?(ralin)
Hi Gijs,

Could you help me to review this patch? Thanks.
Assignee: nobody → ralin
Status: NEW → ASSIGNED
Comment on attachment 8908479 [details]
Bug 1374007 - Remove grey overlay of media controls before media start to play.

https://reviewboard.mozilla.org/r/180138/#review185302

::: commit-message-831e9:1
(Diff revision 1)
> +Bug 1374007 - Remove grey overlay of medai controls before media start to play. r=Gijs

nit:
s/medai/media
Comment on attachment 8908479 [details]
Bug 1374007 - Remove grey overlay of media controls before media start to play.

https://reviewboard.mozilla.org/r/180138/#review185304
Attachment #8908479 - Flags: review+
Thank you Jared, :jya

typo fixed.
Keywords: checkin-needed
Autoland can't push this until all pending issues in MozReview are marked as resolved.
Keywords: checkin-needed
Pushed by jyavenard@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/2125fac068a6
Remove grey overlay of media controls before media start to play. r=jaws
Thanks again :jya
https://hg.mozilla.org/mozilla-central/rev/2125fac068a6
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla57
Build ID: 20170919220202
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0

Verified as fixed on Firefox Nightly 57.0a1 on Windows 10 x 64, Mac OS X 10.12 and Ubuntu 16.04 x64.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.