Cable provider activation not working in v54

RESOLVED INVALID

Status

()

RESOLVED INVALID
2 years ago
2 years ago

People

(Reporter: phredonline, Unassigned)

Tracking

54 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_12_5) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/58.0.3029.110 Safari/537.36

Steps to reproduce:

goto msnbc.com or nbcsports.com or foxnews.com
click on watch live and activate with cable provider account (xfinity)



Actual results:

on msnbc it keeps reloading the verify page. on nbcsports it doesn't even load the page to activate.


Expected results:

the live tv stream should have loaded on msnbc and foxnews and the verify with cable provider should have loaded on nbcsports.

Comment 1

2 years ago
I visited http://www.msnbc.com/now, clicked "Sign In", and selected Comcast (where I have cable service). All tests on Ubuntu.

On Firefox 54 I was sent to
https://login.comcast.net/h/tve_unauthorized_nochannel.html?lang=en
without being asked for my username and password. Text on that page:
> This network is not included in your current XFINITY TV service.
> To add it to your service, upgrade now.
> If you have questions , please see our FAQs or Chat with us.
> Thank you for being an XFINITY customer!

This message came even though I wasn't logged into my Comcast account, and I got the same message after logging into Comcast.

With Nigtly 56 (19 June 2017 version) the "select provider" popup went away. No redirect, no password request.

bugday-20170619
I personally had the same issue with fox.com. I decided to test this out on google chrome and edge which produced the same issue. This is not a firefox issue, this is a provider issue.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INVALID
(Reporter)

Comment 3

2 years ago
I can get it to work in Chrome and Safari on the same computer. It is only Firefox that is showing this issue.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
(Reporter)

Comment 4

2 years ago
Testing on Win10, Chrome works. FF ESR 52.2.0 (64bit) exhibits the same problem.
This still works for me. Hmmm can you try refreshing your profile? That may be the culprit https://support.mozilla.org/en-US/kb/refresh-firefox-reset-add-ons-and-settings
(Reporter)

Comment 6

2 years ago
The reset worked on my MacBook Pro. Interesting that my profile on two different computers would produce the same error. I installed LastPass extension and my Firefox sync and I was able to reproduce the error, once. Then I did a reset again. This time I sync'd my Firefox account and then installed LastPass and I was not able to reproduce it. I'll try it on my Win10 machine to see if it works there too.
(Reporter)

Comment 7

2 years ago
Tested on win10 with ESR 52.2 and a reset fixed the error. I then added back the LastPass extension and the Firefox sync and was not able to reproduce it. But something was there as it happened across devices and versions.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago2 years ago
Resolution: --- → INVALID
I refresh my profile often since I am QA. Usually when I run into janky issues like this a refresh always does the trick. Happy I could help!
You need to log in before you can comment on or make changes to this bug.