Tab moving/reordering/dragable are often broken if "Disable UI Animations" stylesheet or Tab Utilities Fixed enabled in Fx55+

RESOLVED DUPLICATE of bug 1366060

Status

()

Firefox
Tabbed Browser
RESOLVED DUPLICATE of bug 1366060
5 months ago
4 months ago

People

(Reporter: YF (Yang), Unassigned)

Tracking

({regression})

55 Branch
All
Windows 10
regression
Points:
---

Firefox Tracking Flags

(firefox54 unaffected, firefox55 fixed, firefox56 fixed)

Details

(Reporter)

Description

5 months ago
STR:
1. Install the https://addons.mozilla.org/firefox/addon/stylrrr/ (0.1.4), "Disable UI Animations" of its shipping styles is enabled by default.
2. New a few tabs and dragging to reordering them.


Actual results:
1. The tabs may be dislocated (for the mouse pointer, during drag), 
2. stuck (no change order, but the interface changes, and even overlap), 
3. and may not able to dragstart, if "Compact Light" enabled, and second time drag the same tab (no tab switch).

9. Another user reported an about Tab Mix Plus problem with the stylesheet, see the https://addons.mozilla.org/firefox/addon/stylrrr/reviews/884013/.


Expected results:
Any thinking and fixes in Firefox? I understand this bug may be P5 or wontfix, but more hope it is being studied and repaired, because I heard Mozilla intends to add a similar option, as well as the effect of this feature is significant.


Source code of the "Disable UI Animations":
@namespace url(http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul);
@-moz-document url("chrome://browser/content/browser.xul"){
* {	-moz-transition-property: none !important;
	-moz-animation: none !important;
}
}
(Reporter)

Comment 1

5 months ago
Regression range:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=bab7046ee2d82345d7d5b33b8ae4009c7e365176&tochange=e0955584782e6eb13bb1e7b197d3064660bb756f

709528f44f78	Jared Wein — Bug 1355507 - Releasing a tab while dragging through the tabstrip on the same window should show a transition to its final resting place. r=dao
Has Regression Range: --- → yes
Has STR: --- → yes
OS: Unspecified → Windows 10
Hardware: Unspecified → All
(Reporter)

Comment 2

5 months ago
Uh, I just noticed that my another profile also has these problems (#1, #2 and #3) without the extension and the stylesheet (including no userChrome.css), no ideas.
(Reporter)

Comment 3

5 months ago
(In reply to YF (Yang) from comment #2)
> Uh, I just noticed that my another profile also has these problems (#1, #2
> and #3) without the extension and the stylesheet (including no
> userChrome.css), no ideas.

I see the issue with Nightly 56 + Tab Utilities Fixed 1.5.2017.02.04 only + "Compact Light" enabled, don't see an message in the browser console while dragged tab become non-dragable.
Component: Extension Compatibility → Tabbed Browser
Summary: Tab moving/reordering are often broken if "Disable UI Animations" stylesheet enabled in Fx55+ → Tab moving/reordering/dragable are often broken if "Disable UI Animations" stylesheet or Tab Utilities Fixed enabled in Fx55+

Comment 4

5 months ago
This is another consequence of only moving the tab after the animation has finished, see bug 1355507 comment 11. We should reconsider this.
Flags: needinfo?(jaws)
This stylesheet will not work with the patch from bug 1355507 because the code in that patch makes an assumption that transitions are defined. Setting `-moz-transition-property: none !important;` on all elements will break that assumption.

The patch in bug 1366060 adds support for the toolkit.cosmeticAnimations.enabled pref which will be the correct way to disable this animation.
Status: NEW → RESOLVED
Last Resolved: 5 months ago
Flags: needinfo?(jaws)
Resolution: --- → DUPLICATE
Duplicate of bug: 1366060
updating status from bug 1366060
status-firefox55: affected → fixed
status-firefox56: affected → fixed
You need to log in before you can comment on or make changes to this bug.