Closed Bug 1374190 Opened 4 years ago Closed 4 years ago

TEST-UNEXPECTED-FAIL | /builds/slave/test/build/tests/mozmill/content-tabs/test-content-tab.js

Categories

(Thunderbird :: General, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 56.0

People

(Reporter: jorgk-bmo, Assigned: jorgk-bmo)

Details

(Whiteboard: [Thunderbird-testfailure: M Mac])

Attachments

(1 file)

TEST-UNEXPECTED-FAIL | /builds/slave/test/build/tests/mozmill/content-tabs/test-content-tab.js | test-content-tab.js::test_spellcheck_in_content_tabs
TEST-UNEXPECTED-FAIL | /builds/slave/test/build/tests/mozmill/content-tabs/test-content-tab.js | test-content-tab.js::test_content_tab_context_menu

Mac only.

First seen: Sat Jun 17, 2017, 22:50:49
https://treeherder.mozilla.org/#/jobs?repo=comm-central&revision=0cac30b866ef093d76eadbe6d55f5d1c916f39d2

Log:
https://archive.mozilla.org/pub/thunderbird/tinderbox-builds/comm-central-macosx64/1497732683/comm-central_yosemite_r7_test-mozmill-bm107-tests1-macosx-build58.txt.gz

15:16:41     INFO -  SUMMARY-UNEXPECTED-FAIL | test-content-tab.js | test-content-tab.js::test_spellcheck_in_content_tabs
15:16:41     INFO -    EXCEPTION: What, is zombocom a registered word now?
15:16:41     INFO -      at: test-folder-display-helpers.js line 2890
15:16:41     INFO -         assert_true test-folder-display-helpers.js:2890 11
15:16:41     INFO -         test_spellcheck_in_content_tabs test-content-tab.js:85 3
15:16:41     INFO -         Runner.prototype.wrapper frame.js:585 9
15:16:41     INFO -         Runner.prototype._runTestModule frame.js:655 9
15:16:41     INFO -         Runner.prototype.runTestModule frame.js:701 3
15:16:41     INFO -         Runner.prototype.runTestDirectory frame.js:525 7
15:16:41     INFO -         runTestDirectory frame.js:707 3
15:16:41     INFO -         Bridge.prototype._execFunction server.js:179 10
15:16:41     INFO -         Bridge.prototype.execFunction server.js:183 16
15:16:41     INFO -         Session.prototype.receive server.js:283 3
15:16:41     INFO -         AsyncRead.prototype.onDataAvailable server.js:88 3
15:16:41     INFO -  SUMMARY-UNEXPECTED-FAIL | test-content-tab.js | test-content-tab.js::test_content_tab_context_menu
15:16:41     INFO -    EXCEPTION: a != b: '' != 'Click me!'.
15:16:41     INFO -      at: test-folder-display-helpers.js line 2890
15:16:41     INFO -         assert_true test-folder-display-helpers.js:2890 11
15:16:41     INFO -         assert_equals test-folder-display-helpers.js:2877 3
15:16:41     INFO -         test_content_tab_context_menu test-content-tab.js:109 3
15:16:41     INFO -         Runner.prototype.wrapper frame.js:585 9
15:16:41     INFO -         Runner.prototype._runTestModule frame.js:655 9
15:16:41     INFO -         Runner.prototype.runTestModule frame.js:701 3
15:16:41     INFO -         Runner.prototype.runTestDirectory frame.js:525 7
15:16:41     INFO -         runTestDirectory frame.js:707 3
15:16:41     INFO -         Bridge.prototype._execFunction server.js:179 10
15:16:41     INFO -         Bridge.prototype.execFunction server.js:183 16
15:16:41     INFO -         Session.prototype.receive server.js:283 3
15:16:41     INFO -         AsyncRead.prototype.onDataAvailable server.js:88 3

M-C last good: bb8eab3c3ac4147848c4c85d628ba72029
M-C first bad: 90436b206b3d754e482c8d6160274e62a8

https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=bb8eab3c3ac4147848c4c85d628ba72029&tochange=90436b206b3d754e482c8d6160274e62a8

Likely caused by https://hg.mozilla.org/mozilla-central/rev/2ab14fdd3af3 where they wait a second now.

Aceman, I know you love fixing Mac bugs, so here's one for you. Looks like we need to wait for the spellcheck result to arrive.

https://dxr.mozilla.org/comm-central/rev/0cac30b866ef093d76eadbe6d55f5d1c916f39d2/mail/test/mozmill/content-tabs/test-content-tab.js#85

Note that this test only runs on Mac, see test-content-tab.js#97
Flags: needinfo?(acelists)
Whiteboard: [Thunderbird-testfailure: M Mac]
Assignee: nobody → jorgk
Status: NEW → ASSIGNED
Attachment #8880540 - Flags: review?(acelists)
Comment on attachment 8880540 [details] [diff] [review]
1374190-spell-wait.patch

Review of attachment 8880540 [details] [diff] [review]:
-----------------------------------------------------------------

I hoped we can wait on some event here. But I have tried MutationObserver, but it doesn't seem to trigger on the spellchecking pass.

On the other hand, the change fixes the test so that I could enable it on linux locally and it passes.
It seems the comment "XXX Currently the spellcheck test has focus issues on non-Mac" is now true also on Mac and the same change may fix it on all platforms.
So can you enable the test on all platforms now and have a try run?
Attachment #8880540 - Flags: review?(acelists) → review+
https://hg.mozilla.org/comm-central/rev/ea17e74e9fe364786ad0e7b06c8a2eb385938fca

Pushed with the restrictions removed. Let's be daring ;-) - it passed on Windows.
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Flags: needinfo?(acelists)
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 56.0
You need to log in before you can comment on or make changes to this bug.