Closed Bug 1374203 Opened 4 years ago Closed 4 years ago

Permafailing CCov jit failure in relazify.js | evalWithCacheCode.js:2:3 Error: Assertion failed: got false, expected true (code 3, args "") after evalWithCacheCode.js:2:3 Error: Assertion failed: got false, expected true

Categories

(Core :: JavaScript Engine, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla56
Tracking Status
firefox56 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: nbp)

References

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

This is a test case that I added recently, I will investigate later today.
The test case was added in Bug 1330373.

What should I do to reproduce a CCov build locally?
Flags: needinfo?(nicolas.b.pierron)
Blocks: 1330373
Component: JavaScript Engine: JIT → JavaScript Engine
This test case got added in Bug 1330373 and check if decoded function can
successfully be relazified.  Which goes against the code coverage approach
of preventing the relazification in order to keep the counters alive.
Attachment #8879232 - Flags: review?(gmierz2)
Comment on attachment 8879232 [details] [diff] [review]
Skip xdr/relazify.js test case.

Review of attachment 8879232 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks for disabling it for us.
Attachment #8879232 - Flags: review+
Attachment #8879232 - Flags: review?(gmierz2) → review+
Pushed by npierron@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/44031d370133
Code Coverage builds: Skip xdr/relazify.js test case. r=gmierz
https://hg.mozilla.org/mozilla-central/rev/44031d370133
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla56
Assignee: nobody → nicolas.b.pierron
(In reply to OrangeFactor Robot from comment #7)
> 7 failures […] in the last 7 days.   

I do not see how these could happen now that the test case is in the filtered list.
Flags: needinfo?(nicolas.b.pierron) → needinfo?(gmierz2)
Based on the orangefactor graph, it stopped on the 20th of June and nothing else has happened since then. It looks lile it is disabled now though. So, we have nothing to worry about here (unless we get a failure within the next week). :)
Flags: needinfo?(gmierz2)
You need to log in before you can comment on or make changes to this bug.