Closed Bug 1374296 Opened 5 years ago Closed 5 years ago

Decode promise incorrectly rejected under some circumstances

Categories

(Core :: Audio/Video: Playback, enhancement)

enhancement
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1374210

People

(Reporter: jya, Assigned: jya)

References

Details

Attachments

(1 file)

Too quick a change in bug 1374210.

H264Converter::Shutdown now reject the decode promise.

However, H264Converter::Shutdown is called internally as well, during which time we certainly don't want to reject the decode promise.
Comment on attachment 8879164 [details]
Bug 1374296: Don't incorrectly reject promise.

https://reviewboard.mozilla.org/r/150500/#review155168

Pushing now as the next Nightly would be broken otherwise...

Need to investigate why this didn't cause crash with mochitest (the AVC3 one would have exercised that change)
Attachment #8879164 - Flags: review+
We're sorry, Autoland could not rebase your commits for you automatically. Please manually rebase your commits and try again.

hg error in cmd: hg rebase -s 52018df06e66 -d 499a91e7887f: rebasing 402592:52018df06e66 "Bug 1374296: Don't incorrectly reject promise. r=jya" (tip)
merging dom/media/platforms/wrappers/H264Converter.cpp
warning: conflicts while merging dom/media/platforms/wrappers/H264Converter.cpp! (edit, then use 'hg resolve --mark')
unresolved conflicts (see hg resolve, then hg rebase --continue)
Merged those changes with bug 1374210.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1374210
You need to log in before you can comment on or make changes to this bug.