DPI not adjusting when moving FF windows between screens with different DPI settings

UNCONFIRMED
Unassigned

Status

()

P3
normal
UNCONFIRMED
a year ago
a year ago

People

(Reporter: chris, Unassigned)

Tracking

53 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: tpi:+)

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:53.0) Gecko/20100101 Firefox/53.0
Build ID: 20170518000419

Steps to reproduce:

System: Windows 10 Professional Version 1703 Build 15063.413 (has also been happening since before Creators update)
Main Display: 3840 x 2160 landscape with Windows DPI set to 150%
Secondary Display: 1080 x 1920 portrait with Windows DPI set to 100%

1) Run Firefox
2) Browse to any web page (FireFox window opens on high DPI (150%), main display)
3) Move the FireFox browser window to a monitor with a different DPI setting (mine is 100%)


Actual results:

The FireFox browser windows content ends up being much larger in all windows. If I modify the "layout.css.devPixelsPerPx" setting in about:config from "-1.0" to "1.0", the FireFox browser window's content looks 'normal'. However, if at this point I drag the window back over tot he high DPI display, the content is too small.


Expected results:

The FireFox browser window's content should have adjusted as it crossed the various monitors' DPI 'thresholds'. Chrome browser does this successfully.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1228570
I don't think this Windows issue is a dupe of a Linux issue. Widget has a very different implementation for each platform.

That said, bug 890156 should have added multi-monito DPI support on Windows. I don't know why it does not work on reporter's system.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Component: Untriaged → Widget: Win32
Product: Firefox → Core
Priority: -- → P3
Whiteboard: tpi:+
You need to log in before you can comment on or make changes to this bug.