Closed Bug 1374351 Opened 3 years ago Closed 3 years ago

Update platform names for cross-compiled OSX builds

Categories

(Release Engineering :: General, enhancement, P2)

enhancement

Tracking

(firefox56 fixed)

RESOLVED FIXED
Tracking Status
firefox56 --- fixed

People

(Reporter: catlee, Assigned: catlee)

References

Details

Attachments

(4 files)

Attached patch osx-cross.diffSplinter Review
We should use something like "OS X Cross Compiled" and "osx-cross" for the platform names instead of "OS X 10.7" or osx-10.7.
Attachment #8879243 - Flags: review?(kmoir)
Attachment #8879244 - Flags: review?(emorley)
Attachment #8879243 - Flags: review?(kmoir) → review+
Comment on attachment 8879244 [details]
PR for updating treeherder with new names

Please let me know if you need me to merge this.  Otherwise, please feel free to do so yourself.  :)
Attachment #8879244 - Flags: review?(emorley) → review+
(In reply to Cameron Dawson [:camd] from comment #2)
> Please let me know if you need me to merge this.  Otherwise, please feel
> free to do so yourself.  :)

95% of the time, if someone isn't a core-dev they (by design) won't have push access to the repo. The list of people with permissions is available here:
https://github.com/orgs/mozilla/teams/treeherder/members

I've merged this now (also fixed up the commit message to include the bug number via the github squash+merge message edit feature). It will be on stage within a few minutes, and prod as of the next deploy (few days to a week depending on what else is going on).

Thank you for the PR :-)
(In reply to Treeherder Bugbot from comment #4)
> Commit pushed to master at https://github.com/mozilla/treeherder
> 
> https://github.com/mozilla/treeherder/commit/
> 8a43fa9a0c0101ab7250211087de60ea2528c710
> Bug 1374351 - Add platform names for cross compiled OSX builds (#2578)

Ed, can you let me know when this is deployed to production?
Flags: needinfo?(emorley)
I've started a production deploy now, CI and subsequent build should finish shortly (watch for heroku bot announcement in #treeherder).
Flags: needinfo?(emorley)
Comment on attachment 8883319 [details]
Bug 1374351: Update platform names for cross-compiled OSX builds

https://reviewboard.mozilla.org/r/154218/#review159600
Attachment #8883319 - Flags: review?(bugspam.Callek) → review+
Pushed by catlee@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/77acba0717ca
Update platform names for cross-compiled OSX builds r=Callek
https://hg.mozilla.org/mozilla-central/rev/77acba0717ca
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Blocks: 1379929
You need to log in before you can comment on or make changes to this bug.