Status

()

Toolkit
Application Update
RESOLVED DUPLICATE of bug 1375242
7 months ago
6 months ago

People

(Reporter: tkdubiel, Unassigned)

Tracking

56 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(5 attachments)

(Reporter)

Description

7 months ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/59.0.3071.104 Safari/537.36

Steps to reproduce:

I checked for Nightly updates. I downloaded today version, clicked to restart and after that nothing happens. When I want to launch Nightly again, nothing happens. I need to reboot computer and do the same.
(Reporter)

Updated

7 months ago
Summary: dwbg → I can't update
(Reporter)

Updated

7 months ago
Summary: I can't update → I can't update Nightly

Updated

7 months ago
Component: Untriaged → Application Update
Product: Firefox → Toolkit
There is a good chance this is a duplicate of bug 1370576 which also fixes bug 1368600. Please manually install the latest and then when the next update happens please comment in this bug as to whether it is still happening. Thanks!
(Reporter)

Comment 2

7 months ago
Well, I can't even launch Nightly after update. I will update manually.
(Reporter)

Comment 3

7 months ago
Today the same has happened. I clicked "Restart to apply updates" and that was all. Nothing happened further. 
I recognised that after I click to restart Nightly, nothing happens, but there are Nightly processes visible in Task Manager. When I kill them, I can launch Nightly, but it's not updated. It will download update and everything will be repeated.
After experiencing this issue (if you haven't reinstalled the current state should be fine) please perform the following:

1. Type about:config in the url bar.
2. Click the button that is shown.
3. Copy devtools.chrome.enabled into the search bar.
4. Toggle the value from false to true by either double clicking it or via the context menu.
5. Under Tools -> Web Developer select Browser Console.
6. Copy and paste the following into the text box at the bottom
var fileLocator = Cc["@mozilla.org/file/directory_service;1"].getService(Ci.nsIProperties); var dir = fileLocator.get("UpdRootD", Ci.nsIFile); dir.reveal();

7. From the directory that is opened attach the active-update.xml and updates.xml files to this bug
8. In the updates subdirectory attach the last-update.log and the backup-update.log files if they exist.
9. In the 0 subdirectory attach the update.log and the update.status files if they exist.
(Reporter)

Comment 5

7 months ago
Created attachment 8879651 [details]
active-update.xml
(Reporter)

Comment 6

7 months ago
Created attachment 8879652 [details]
last-update.log
(Reporter)

Comment 7

7 months ago
Created attachment 8879653 [details]
updates.xml
(Reporter)

Comment 8

7 months ago
I will probably have to do it again tomorrow, because when Nightly didn't start after clicking "Restart", I killed Nightly process and after crash it seems to be updated.
(Reporter)

Comment 9

7 months ago
I will now uninstall Nightly, install yesterday version, try to update and reboot my PC. After that I will attach again xml and log files.
(Reporter)

Comment 10

7 months ago
Created attachment 8879657 [details]
cant_update.7z
(Reporter)

Comment 11

7 months ago
In updates folder there was only folder 0. In 0 folder there was no update.log file, apart from update.status file there were also logEA1.tmp, update.mar and update.version.
(Reporter)

Comment 12

7 months ago
Created attachment 8879661 [details]
When I click "Restart to apply updates", Nightly closes, for few seconds I see spinning wheel of loading  and in Task Manager I see this. It remains unless I kill it.
It seems that the firefox.exe process isn't exiting. Could you try again and let it sit for at least two minutes without doing anything else and then check in task manager for the Nightly (e.g. firefox.exe) and the Nightly Software Updater (e.g. updater.exe) processes?
Flags: needinfo?(to_du)
(Reporter)

Comment 14

7 months ago
I checked now. After 2 minutes nothing happened, I noticed in Task Manager one Nightly process. When I tried to launch Nightly, nothing happened, only second Nightly process appeard.
Flags: needinfo?(to_du)
Thank you. This helps narrow down where the problem actually resides.

Could you try the following?
Setup your environment so you are running a version that has an update available if necessary. Type about:config in the url bar, click the warning button if shown, and change browser.tabs.remote.autostart preference to false. Then exit Firefox and relaunch it. Verify that the browser.tabs.remote.autostart is still false and try to update. Thanks!
(Reporter)

Comment 16

7 months ago
I checked in another way. After downloading update I closed Nightly. In Task Manager there was no Nightly process. When I launched it, Nightly and Nightly Software Updater were present, updater disappeard after about minute and that was all. Nightly wasn't updated.
(Reporter)

Comment 17

7 months ago
Do it or my previous comment tells you something about that?
(Reporter)

Comment 18

7 months ago
*Should I do it...
Could you attach the *.logs again from comment #4?

8. In the updates subdirectory attach the last-update.log and the backup-update.log files if they exist.
9. In the 0 subdirectory attach the update.log and the update.status files if they exist.

After that try it again using the steps in comment #15
(Reporter)

Comment 20

7 months ago
I tried. I had autostart, autostart1 and autostart2 preferences, First 2 were set to false, third to true. I changed third to be false. Updated. I see in Task Manager Nightly and NIghtly Software Updater and second one disappears after one minute.
(Reporter)

Comment 21

7 months ago
I will now do it all again.
(Reporter)

Comment 22

7 months ago
Well, I once again installed version which has update. Some time after no reaction I killed Nightly process and didn't kill updater process. Updating then went well. 
I don't know why, but I don't have now text box in Browser Console available.
Since this involves the firefox.exe process not exiting I filed bug 1375242 and cc'd several developers that will hopefully be able to help with that issue. Thanks for proving the info I requested.
I've changed the updater in Bug 1375549 so it will apply the update anyways so if there is a fix for the Firefox (other applications as well) process not exiting the client will get the fix and to not try to launch Firefox (other applications as well) when the process hasn't exited. This should merge into Nightly in a couple of days.

The issue with Firefox (other applications as well) will need to be fixed in Bug 1375242 so I am duplicating this bug to that bug. Hopefully they will be able to get the information they need to fix that bug. Thanks!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1375242
I could't reproduce this issue following the STR from comment 0. On my machines (Windows 10 x64, Windows 7 x86) the affected Nightly build was updated as expected to the current version. 

I only manged to reproduce bug 1376612 but it seems that is not related to the this bug.

Since I am not able ro reproduce this issue, tkdubiel@gmail.com could you please help us verifying this issue with some recent Nightly [1] 56.01 builds?

Thank you!

[1] https://archive.mozilla.org/pub/firefox/nightly/2017/07/2017-07-15-10-02-14-mozilla-central/
https://archive.mozilla.org/pub/firefox/nightly/2017/07/2017-07-16-10-03-25-mozilla-central/
Flags: needinfo?(tkdubiel)
(Reporter)

Comment 26

6 months ago
There is no problem at least for two weeks. I don't see any reason to try with some builds. Nightly updates without any problems for about two weeks or more.
Flags: needinfo?(tkdubiel)
You need to log in before you can comment on or make changes to this bug.