mouse pointer changes to magnifier, such that links on images become unclickable when reading pane is reduced in size

RESOLVED DUPLICATE of bug 1227787

Status

Thunderbird
Message Reader UI
--
minor
RESOLVED DUPLICATE of bug 1227787
4 months ago
13 days ago

People

(Reporter: Todd, Unassigned)

Tracking

52 Branch

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 months ago
Created attachment 8879323 [details]
While it's hard to see the cursor is actually a magnifier and not a hand

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/58.0.3029.110 Safari/537.36

Steps to reproduce:

Size TB to about 2/3 of the screen horizontally (across).  At some point as you down size  from maximized your hand turns to a magnifier.  As you continue to minimize it may go back and forth multiple times.


Actual results:

Links become unclickable, sometimes a <H> might be clickable while the rest of the clickable text remains unclickable


Expected results:

There should be no difference regardless of the size of the pane.

Updated

4 months ago
Component: Untriaged → Message Reader UI
Summary: Reading pane links become unclickable when TB is not maximized → links become unclickable when reading pane is reduced in safe

Comment 1

4 months ago
You're on Windows, since I can see cmd32 on your desktop. What do you mean by "hands"? And "magnifier"? When I resize the window, I see a double arrow at the edge, like <-->

Does this happen with all add-ons disabled, see Help menu to start TB without add-ons.

Updated

4 months ago
Summary: links become unclickable when reading pane is reduced in safe → links become unclickable when reading pane is reduced in size
(Reporter)

Comment 2

4 months ago
I restarted in Safe Mode and I was not able to recreate the problem.  Then I went back to regular mode and I was not able to recreate the problem.  I have no add-ons that would have anything to do with magnifying or sizing FYI.

Then it began again.  I had gone through several emails without a problem and for whatever reason on a Youtube upload announcement, it happened again even though the very first email I looked at was a Youtube that worked without a problem.  This time I marked the location of the TB window so I could recreate that size in Safe Mode and I went to that same video and the same thing happened.  I move my cursor over the title of the video and I get a hand but when I move the cursor over the video itself it becomes a magnifying glass and will not open the link.

Using jRuler I took a measurement 1020 x 781 pixels that was the entire TB window.  200 pixels takes me from the left edge to the right of the account/folder slider and 520 to the right of the slider for the message list pane.  I had Chrome opened to the right of those measurements.  It's a 17" screen 15" x 8.5".

I'm not talking about your cursor on the edge while you are downsizing (what link would you click on the edge?)  I'm talking about after you've downsized it and move your cursor onto the reading pane you may get a magnifier or you may get a hand (clickable link) but it's not consistent so at 100% you will always see the hand, at 80% you may see a magnifier, at 75% you may go back to a hand or you may get a magnifier.  But it should always be a hand because it's a clickable link regardless of the size of TB and it's reading pane.  See the image I uploaded.  I would've uploaded more but you only allow one image per problem.

Comment 3

22 days ago
Does it also happen with beta? 
 http://www.mozilla.org/en-US/thunderbird/channel/
Flags: needinfo?(todd.bugzilla)
(Reporter)

Comment 4

20 days ago
First off let me say you people are nuts with your constant password changes.  It's so bad that I don't even want to report problems anymore, in fact, I have not reported the last one that I incurred because as usual, I had to go through figuring out why my password wasn't working yet again.  So knock it the "F" off.

Secondly, there was absolutely no reason you couldn't test this yourself but I did and it doesn't work any better in the Beta.
Flags: needinfo?(todd.bugzilla)

Comment 5

13 days ago
Well, frankly it was a bit hard to follow, and without a test message. 
But I believe this is a duplicate of bug 1227787
Severity: normal → minor
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 days ago
Resolution: --- → DUPLICATE
Summary: links become unclickable when reading pane is reduced in size → mouse pointer changes to magnifier, such that links on images become unclickable when reading pane is reduced in size
Duplicate of bug: 1227787
You need to log in before you can comment on or make changes to this bug.